[webrtc-encoded-transform] Terminology: Encrypter or encryptor? (#311)

alvestrand has just created a new issue for https://github.com/w3c/webrtc-encoded-transform:

== Terminology: Encrypter or encryptor? ==
This came up in an implementation discussion.
Apparently there's precedent out there; Gemini says:

Go with decryptor (with an "-or").

While both decrypter and decryptor are technically correct in the English language, decryptor is the overwhelming favorite in software engineering, cryptography, and computer science.

Here is why, along with a few rules of thumb for your codebase:

1. Industry Precedent
Major tech frameworks have already established "-or" as the standard. For example, Microsoft’s .NET framework explicitly uses the methods CreateEncryptor() and CreateDecryptor(). Following industry precedent makes your code feel more intuitive to other developers.

2. The "Object vs. Person" Convention
In technical naming conventions, the "-or" suffix is frequently used for automated software agents, hardware devices, or specialized system components (e.g., processor, compressor, descriptor, incubator).

Conversely, "-er" often implies a person performing the action (like a hacker acting as a codebreaker or decrypter), though there are obvious exceptions like computer and printer.

Please view or discuss this issue at https://github.com/w3c/webrtc-encoded-transform/issues/311 using your GitHub account


-- 
Sent via github-notify-ml as configured in https://github.com/w3c/github-notify-ml-config

Received on Thursday, 4 June 2026 13:17:04 UTC