W3C home > Mailing lists > Public > xproc-dev@w3.org > April 2014

Re: Setting a Schematron 'let' variable via XProc

From: GOOCH, Phil <phil.gooch@oup.com>
Date: Wed, 9 Apr 2014 15:50:22 +0100
To: "xproc-dev@w3.org" <xproc-dev@w3.org>
Message-ID: <04E229667EEBCF4E9A075810ECA4665F3D32F9B8FA@UKMB02.uk.oup.com>
Thanks Gerrit, I will give this a try. In my case, using base-uri() won't help, as the file I want to reference in the Schematron ruleset is located in a directory relative to the Schematron .sch and Xproc .xpl files, not the XML file being processed/validated.

Thanks again for your detailed and helpful response.

Cheers

Phil


Phil Gooch
Senior Language Technologist
Language Technology Group
Global Academic Business, Dictionaries
Oxford University Press | Great Clarendon Street | Oxford OX2 6DP

E: phil.gooch@oup.com
T: +44 (0)1865 354987
M: +44 (0)7876 881998


Oxford University Press (UK) Disclaimer

This message is confidential. You should not copy it or disclose its contents to anyone. You may use and apply the information for the intended purpose only. OUP does not accept legal responsibility for the contents of this message. Any views or opinions presented are those of the author only and not of OUP. If this email has come to you in error, please delete it, along with any attachments. Please note that OUP may intercept incoming and outgoing email communications.
Received on Thursday, 10 April 2014 02:34:48 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:03:12 UTC