Re: Getting from "Good Start" to "Great Solution” . . ?

On Thu, Feb 7, 2013 at 9:25 AM, Norman Walsh <ndw@nwalsh.com> wrote:

> >     For example:
> >
> >         • “view-port” as a step name is not consistent with naming
> >           that clearly conceptually relates from numerous other
> programming
> >           languages. A far more consistent and intuitive name would have
> been
> >           “for-each-node” or “for-each-fragment” or “for-each-match”.
>
> You don't think that would raise significant confusion with respect to
> the existing p:for-each step?
>

I feel like suggesting the following even though it's a bit far out...

   1. combine for-each and viewport as just for-each
   2. take iteration-source functionality externally
   3. add an attribute to copy-unmatched ="true|false" dictating to copy
   the parts of the document that are not matched
   4. Handle multiple iteration-source documents by removing the
   p:iteration-source into it's own step which would surround steps.

<book>
<p:iterate select=" ">
 <p:for-each match="//chapter" copy-unmatched="true">

  <p:xslt...

 </p:for-each>
</p:iterate>
</book>

I suppose I'm doing something here a little more like xslt by adding <book>
rather than p:wrap-sequence. If one put p:iterate like that I wonder could
any other step follow it than p:for-each. Perhaps there is no point of
doing this although it might be easier given the combination of viewport
and for-each if that is logical.

Thoughts?
-- 
-

Alex G. Muir
Software Engineering Consultant
Linkedin Profile : http://ca.linkedin.com/pub/alex-muir/36/ab7/125
Love African Kora Music? Take a moment to listen to Gambia's - Amadu
Diabarte & Jali Bakary Konteh www.bafila.bandcamp.com Your support keeps
Africa's griot tradition alive... Cheers!

Received on Thursday, 7 February 2013 15:59:47 UTC