W3C home > Mailing lists > Public > xproc-dev@w3.org > September 2012

Re: Strange behavior involving (p:)resolve-uri, variables, attributes, calabash, oxygen, saxon, ...

From: Romain Deltour <rdeltour@gmail.com>
Date: Mon, 24 Sep 2012 21:21:11 +0200
Message-Id: <CE316AA3-6FE1-4465-B5E5-EEA0E6B20260@gmail.com>
To: XProc Dev <xproc-dev@w3.org>
For George and Norm mostly:

Here's a small repro that crashes with the "Internal Saxon error" on oXygen but not with vanilla Calabash. I've not tried with Calabash + Saxon EE.

Romain.

On 16 août 2012, at 17:56, Romain Deltour <rdeltour@gmail.com> wrote:

> Any news on this issue ?
> 
> I'm stuck on the same issue as Jostein's, although replacing all invokes of p:resolve-uri by fn:resolve-uri didn't work for me.
> 
> Thanks
> Romain.
> 
> On 13 déc. 2011, at 15:32, Norman Walsh <ndw@nwalsh.com> wrote:
> 
>> George Cristian Bina <george@oxygenxml.com> writes:
>>> I am not sure if there is something that we can fix as the problem may 
>>> be in Saxon. I will try to see if I can force Calabash to use Saxon EE 
>>> outside oXygen to try to reproduce this issue.
>> 
>> I succeeded. There's clearly something weird going on here. If I tell
>> Calabash to require an EE processor, it reports an EE processor but
>> also reports that psvi-required="true" isn't supported. And the test
>> succeeds.
>> 
>> If I tell Calabash to require an EE processor, and tell it to load a
>> Saxon configuration file, then it doesn't object to
>> psvi-required="true" and the test fails.
>> 
>> I'm not sure what that means, but I'll report it and see if I can come
>> to a better understanding of what's going on.
>> 
>>                                       Be seeing you,
>>                                         norm
>> 
>> -- 
>> Norman Walsh
>> Lead Engineer
>> MarkLogic Corporation
>> Phone: +1 413 624 6676
>> www.marklogic.com
> 
Received on Monday, 24 September 2012 19:21:56 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 24 September 2012 19:21:57 GMT