W3C home > Mailing lists > Public > xmlschema-dev@w3.org > June 2010

Re: Your XML validator is broken

From: Michael Kay <mike@saxonica.com>
Date: Wed, 09 Jun 2010 08:14:37 +0100
Message-ID: <4C0F3F5D.6090906@saxonica.com>
To: jesse <jjesterj@msn.com>
CC: xmlschema-dev@w3.org
On 09/06/2010 03:20, jesse wrote:
> Hi there, I'm writing to inform you that your xml validator at: 
> http://www.w3.org/2001/03/webdata/xsv is malfunctioning.  It says 
> there's an error in my sitemap, I also checked my sitemap in Google's 
> xml validator and it validated.  Just to verify my results, I checked 
> google's sitemap in their validator and yours and got the same results.
>
> <http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_2>

This information is not useful unless you tell us where to find your 
sitemap, and preferably tell us what the error messages were.

The fact that two validators A and B give different results does not 
prove that A is broken. Very often when this happens you will find that 
the stricter validator (the one that reports the errors) is the one that 
is correct.

Incidentally, there's no particular "you" whom you are addressing by 
posting on this list. The list is a community resource; if the message 
is intended for someone in particular, you should say so.

Michael Kay
Saxonica
Received on Wednesday, 9 June 2010 07:15:11 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 11 January 2011 00:15:21 GMT