W3C home > Mailing lists > Public > xmlschema-dev@w3.org > December 2008

RE: w3-validator

From: <Simon.Cox@csiro.au>
Date: Fri, 12 Dec 2008 13:07:26 +0900
To: <dwight.modiwirijo@mx-groep.nl>, <xmlschema-dev@w3.org>
Message-ID: <5D27281509882544A841804E4EBA914C02222D0F40@EXWA-MBX01.nexus.csiro.au>
Proliferation of unauthorized versions of schemas is bound to cause problems later, especially when there is a canonical version available from a public repository. I wish people wouldn't do that.

Simon

______
Simon.Cox@csiro.au  CSIRO Exploration & Mining
26 Dick Perry Avenue, Kensington WA 6151
PO Box 1130, Bentley WA 6102  AUSTRALIA
T: +61 (0)8 6436 8639  Cell: +61 (0) 403 302 672
Polycom PVX: 130.116.146.28
<http://www.csiro.au<http://www.csiro.au/>>

ABN: 41 687 119 230



________________________________
From: Modiwirijo, Dwight [mailto:dwight.modiwirijo@mx-groep.nl]
Sent: Wednesday, 10 December 2008 6:27 PM
To: Cox, Simon (E&M, Kensington); xmlschema-dev@w3.org
Subject: RE: w3-validator

Hi,

Thanx for your reply. I suggested this solution earlier to the supplier of those local XSD's. But they (KlicWab & GEODAN) refused the 2.1.2 version.
The goal of this thread is to understand whether the locals are actual incorrect or not. Meanwhile the supplier created another 'version' of 2.1.2 which can be validated.

regards,
Dwight
-----Oorspronkelijk bericht-----
Van: Simon.Cox@csiro.au [mailto:Simon.Cox@csiro.au]
Verzonden: dinsdag 9 december 2008 21:49
Aan: Modiwirijo, Dwight; xmlschema-dev@w3.org
Onderwerp: RE: w3-validator

I suggest you use the documents from the official release site
http://schemas.opengis.net/gml/2.1.2/
instead of your local clone.
This one was last bug-fixed in 2007 - I think I recall it was to deal with exactly this problem.

Simon Cox

______
Simon.Cox@csiro.au  CSIRO Exploration & Mining
26 Dick Perry Avenue, Kensington WA 6151
PO Box 1130, Bentley WA 6102  AUSTRALIA
T: +61 (0)8 6436 8639  Cell: +61 (0) 403 302 672
Polycom PVX: 130.116.146.28
<http://www.csiro.au<http://www.csiro.au/>>

ABN: 41 687 119 230



________________________________
From: xmlschema-dev-request@w3.org [mailto:xmlschema-dev-request@w3.org] On Behalf Of Modiwirijo, Dwight
Sent: Monday, 1 December 2008 3:45 PM
To: xmlschema-dev@w3.org
Subject: w3-validator


Hi,

I have used the validator(http://www.w3.org/2001/03/webdata/xsv#hlp-warn) to validate:

 *   http://iwsr.mx-systems.nl/krwint/test/klic/xsd_klic/geometry.xsd
 *   http://iwsr.mx-systems.nl/krwint/test/klic/xsd_klic/klic_feature.xsd

The result:
http://hellow0rld.googlecode.com/svn/branches/XSD.klicwab/result.xml shows that there is no schema-error.

But if I use my own validator (http://hellow0rld.googlecode.com/svn/trunk/Projects/klic.generated.source/klic_wab_geometrieTest/Backup/Bin/Release/GMLvalidator.exe) or Altova then I got schema-errors.

What must I do to use the w3-validator correctly if I did something wrong?

Regards
Dwight


MX.Systems
Patrijsweg 32, 2289 EX Rijswijk

tel.: 070 3073768
fax: 070 3073700

website: <http://www.mx-groep.nl/>
e-mail: <mailto:dwight.modiwirijo@mx-groep.nl>
Received on Friday, 12 December 2008 04:08:27 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 11 January 2011 00:15:09 GMT