W3C home > Mailing lists > Public > xmlschema-dev@w3.org > September 2005

Duplicate attribute uses (Xerces bug?)

From: Kasimier Buchcik <kbuchcik@4commerce.de>
Date: Mon, 12 Sep 2005 13:29:40 +0200
To: XML-SCHEMA <xmlschema-dev@w3.org>
Message-Id: <1126524580.1272.11.camel@librax>

Hi,

Don't worry; this is not related to schema construction.
I get an error report from Xerces-J 2.7.1 when
prohibiting and defining an equal attribute use in the
same type.

attr.xsd
--------
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
	targetNamespace="urn:test:foo"
	xmlns:f="urn:test:foo">

	<xsd:complexType name="base">
		<xsd:attribute name="boo" use="optional"/>
	</xsd:complexType>

	<xsd:complexType name="type">
		<xsd:complexContent>
			<xsd:restriction base="f:base">
				<xsd:attribute name="boo" use="prohibited"/>
				<xsd:attribute name="boo"/>
			</xsd:restriction>
		</xsd:complexContent>
	</xsd:complexType>

	<xsd:element name="foo" type="f:type"/>
</xsd:schema>

attr.xml
--------
<foo xmlns="urn:test:foo"
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	xsi:schemaLocation="urn:test:foo attr.xsd"/>

XSV: no errors
Xerces:
attr.xsd:14,32: (Error) ct-props-correct.4: Error for type 'type'.
Duplicate attribute uses with the same name and target namespace are
specified.  Name of duplicate attribute use is 'boo'.

IFAIK prohibiting an attribute does not create an attribute use
component and is just a mechanism to prohibit attribute uses
of the base type. So I see no error here.
Thoughts?

Regards,

Kasimier
Received on Monday, 12 September 2005 11:46:55 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 11 January 2011 00:14:50 GMT