W3C home > Mailing lists > Public > xmlschema-dev@w3.org > April 2004

Beginner's Question - Schema Validation Problem

From: Ayman El-Geneidy <aelgeneidy@insightbb.com>
Date: Wed, 7 Apr 2004 10:15:58 -0400
Message-ID: <000801c41caa$da73d9a0$6401a8c0@ayman1>
To: <xmlschema-dev@w3.org>
I am trying to validate a schema and getting the error "Element 'qos' is used but not declared in DTD/Schema". 'qos' is my root element. I have looked at several books and at similar messages on this list with no luck.

This is how I am declaring it in my XML file:




And this is how it is declared in the schema file ('qos.xsd' located at the same directory as the XML file):

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema">


     <xsd:element name="qos" maxOccurs="1">
               <xsd:element ref="performance" minOccurs="0"    maxOccurs="1"/>
           <xsd:element ref="information" minOccurs="0" maxOccurs="1"/>
           <xsd:element ref="configuration" minOccurs="0" maxOccurs="1"/>
           <xsd:element ref="security" minOccurs="0" maxOccurs="1"/>   
      <xsd:attribute ref="service_key" use="required"/>


I have tried qualifying the path of the xsd file as it was explained in a previous message and got the same result. I am using the XRay editor from Architag.

I would appreciate any help and guidance.

Thank you.

Received on Wednesday, 7 April 2004 10:59:06 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 14:56:04 UTC