W3C home > Mailing lists > Public > xmlschema-dev@w3.org > October 2002

I am having a problem with using XSD & XSL in the same document

From: vze3y7w8 <boris.kortiak@verizon.net>
Date: Tue, 22 Oct 2002 20:43:39 -0400
To: "Xmlschema Mailing List" <xmlschema-dev@w3.org>
Message-ID: <003001c27a2d$3b428f50$33fc5044@VAIO590G01>
I am working with my family on developing a family tree.  I am using
XMLSPY to do the development.  I am having a problem using XSD and XSL
in the same document.

 

If you look at
http://users.erols.com/bpkprsnl/Kortiak/FamilyTree_xsd.xml you should
see a table of various members of my family.

 

If you look at the XML source, about the third line down, you will see a
commented out root declaration with information about the CSD as
generated by XMLSPY.

 

The problem I am having is that if I restore that line and comment out
the other root declaration I only get the data contents of the XML
document and no XSL formatting is performed.

 

How do I correct this?  Pointer to on-line resources would be greatly
appreciated (I do not mind RTFM; I just do not which M to R).

 

In addition, if you are aware of any projects which have already created
schemas for genealogy (other than gedML, which seems not to have seen
any activity in a long while), I would greatly appreciate the info.

 

TIA for any hints you can provide.

--
boris@kortiak.com
http://www.boriskortiak.com/

 
Received on Tuesday, 22 October 2002 20:44:08 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 11 January 2011 00:14:34 GMT