W3C home > Mailing lists > Public > www-xsl-fo@w3.org > January 2009

Re: Table top Row

From: Saqi <saqib.javed@gmail.com>
Date: Fri, 2 Jan 2009 12:10:31 +0500
Message-ID: <e43b65bd0901012310q1b469ee2qf0630d533386d543@mail.gmail.com>
To: www-xsl-fo@w3.org
Hello,
I found an answer for my problem.
set the table properties
border-after-width.length="1pt"
border-after-width.conditionality="retain"
border-before-width.length="1pt"
border-before-width.conditionality="retain"
and the problem is solved...
Thanks,
Regards,
Saqib Javed

On Wed, Dec 31, 2008 at 9:39 AM, Saqi <saqib.javed@gmail.com> wrote:

> AoA,
> Thanks for your response. I'm using Antenna Xsl-formatter.
>  yes i've tried fo:table-body's border properties but my problem was not
> solved.
> I think i've explained my problem very well.
> The attched files show what problem actually occuring here. the first page
> is fine. 2nd page is also appears fine header is ommited as required but the
> top border also disappears. i want it there.
>
> Thanks
>
> Regards,
> Saqib Javed
>
>
> On Tue, Dec 30, 2008 at 7:56 PM, Tony Graham <
> Tony.Graham@menteithconsulting.com> wrote:
>
>>
>> On Tue, Dec 30 2008 04:45:33 +0000, saqib.javed@gmail.com wrote:
>> > i'm designing a table in xsl-fo. now i've to show only the table column
>> lines
>> > and table row lines are ommited. now when i try to set
>> > table-omit-header-at-break="true". when the data overflow to the next
>> page, yes
>> > header is ommited but the top line also disappear. now i just want to
>> show that
>> > top line without showing the header. is there any thing i am missing. my
>> code
>> > islike this.
>> >
>> > <fo:table table-omit-footer-at-break="false"
>> table-omit-header-at-break="true"
>> > border="1pt" border-style="solid" >
>> >
>> >             <fo:table-column width="30mm"/>
>> >             <fo:table-column width="30mm"/>
>> >
>> >                 <fo:table-header>
>> ...
>> >               </fo:table-row>
>> >             </fo:table-header>
>> >
>> >             <fo:table-footer/>
>> >
>> >             <fo:table-body>
>> ...
>>
>> You don't say which XSL formatter you are using.
>>
>> Have you tried setting the border properties of fo:table-body?
>>
>> Regards,
>>
>>
>> Tony Graham                         Tony.Graham@MenteithConsulting.com
>> Director                                  W3C XSL FO SG Invited Expert
>> Menteith Consulting Ltd
>> XML, XSL and XSLT consulting, programming and training
>> Registered Office: 13 Kelly's Bay Beach, Skerries, Co. Dublin, Ireland
>> Registered in Ireland - No. 428599   http://www.menteithconsulting.com
>>  --  --  --  --  --  --  --  --  --  --  --  --  --  --  --  --  --
>> xmlroff XSL Formatter                               http://xmlroff.org
>> xslide Emacs mode                  http://www.menteith.com/wiki/xslide
>> Unicode: A Primer                               urn:isbn:0-7645-4625-2
>>
>>
>
Received on Friday, 2 January 2009 07:11:08 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 2 January 2009 07:11:09 GMT