W3C home > Mailing lists > Public > www-xsl-fo@w3.org > October 2003

Re: page sequences and static content

From: Daniel Easton <daniel@acidy.com>
Date: Thu, 30 Oct 2003 16:05:49 -0000
Message-ID: <072b01c39eff$afaf3490$a100a8c0@dan>
To: "Victor Vishnyakov" <tch_@mail.ru>, <www-xsl-fo@w3.org>
Dear all,

Attached is the input xml (called mrml) and the xslfo stylesheet to convert
to valid fo.

Still struggling to get header and footer appear at the top and bottom of
every page.

Many thanks for any help in advance,

Cheers

Daniel

----- Original Message ----- 
From: "Victor Vishnyakov" <tch_@mail.ru>
To: "'Daniel Easton'" <daniel@acidy.com>; <www-xsl-fo@w3.org>
Sent: Thursday, October 30, 2003 3:46 PM
Subject: RE: page sequences and static content


> Try posting your xsl-fo( xsl file from your first posting mean nothing
> without sample xml ) here to see where the problem is.
>
> Regards,
> Victor Vishnyakov
>
>
>
>
> [ skipped ]
>
> >
> > Is there anything else I'm missing ??
> >
>
> [ skipped ]
>
> > > Your region-before and region-after is unnamed, thus formatter cant
> > > associate static-content to its region.
> > >
> > > Try the following:
> > >
> > > <fo:region-before display-align="after"
> > > region-name="xsl-region-before"> .. <fo:region-after
> > > display-align="before"  region-name="xsl-region-after">
> > >
> > > See spec 7.25.17 "region-name" and 7.25.5 "flow-name" for details
> > >
> [ skipped ]
>
> > > >
> > > > Not sure if this is the correct list to write to (if it is
> incorrect
> > > > please accept my apologies) but am having some difficulty with an
> > > > XSL FO document.
> > > >
> > > > Briefly my current set up involves formatting my initial
> > data into
> > > > my own ML and then transforming into the fo namespace so I can
> > > > transform to a pdf using FOP.  My problem specifically is
> > that I am
> > > > generating header and footer content (in the static-content tags)
> > > > from the intermediary ML which is only showing on the first page.
> > > >
> > > > I have narrowed this problem down to 2 possible causes:
> > > >
> > > > 1) fo:static-content is only able to handle simple
> > content hardcoded
> > > > in the xsl and not dynamically generated content from my ML
> > > > language(which was not my understanding of the xsl
> > specification - I
> > > > thought static-content referred to content which appears on every
> > > > page)
> > > >
> > > > 2) I am not correctly defining the page sequence and page
> > templates
> > > > correctly.
> > > >
> > > > My code is attached.
> > > >
>
> [ skipped ]
>
>
>


Received on Thursday, 30 October 2003 11:05:37 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 3 October 2007 16:06:11 GMT