W3C home > Mailing lists > Public > www-xsl-fo@w3.org > September 2002

Re: span text into a page with 2-column layout

From: Hong Jiang <hjiang@obj-x.com>
Date: Tue, 17 Sep 2002 11:03:54 -0400
Message-ID: <003701c25e5b$70ddbc90$2401a8c0@theepic.com>
To: "G. Ken Holman" <gkholman@CraneSoftwrights.com>, <www-xsl-fo@w3.org>

Thanks.

Let me explain what I did with span="all".
First, I put the span="all" in the block where I want to span to 2 columns,
just like the following code.
  <fo:block space-before="10mm" >
    <xsl:for-each select="report/overview/notes">
     <fo:block text-align="start" font-family="Arial" font-style="italic"
      font-size="8pt"  space-start="3mm" span="all">
    <xsl:value-of select="."/>
     </fo:block>
    </xsl:for-each>
  </fo:block>

I used the FOP0.20.4 to generate the PDF which did not span the notes at
all. See Fig. 1 in attached file.

Then, I changed the XSL to the following, added span="all" to outer level
block too.
  <fo:block space-before="10mm"  span="all">
    <xsl:for-each select="report/overview/notes">
     <fo:block text-align="start" font-family="Arial" font-style="italic"
      font-size="8pt"  space-start="3mm" span="all">
    <xsl:value-of select="."/>
     </fo:block>
    </xsl:for-each>
  </fo:block>

This time, it spanned all blocks  and tables in the page. See Fig. 2 in
attached file.

And what I want is in Fig. 3.

I did some search on the internet and found the following statements in
http://www.w3.org/TR/2000/WD-xsl-20000327/slice7.html#span


7.18.5 "span" XSL Definition:

Value:  none | all | inherit
Initial:  none
Applies to:  see prose
Inherited:  no
Percentages:  N/A
Media:  visual

Values have the following meanings:
none    This object does not span multiple columns.
all     The areas resulting from this flow object shall span all the columns
of a multi-column region.
    Specifies if a block-level object should be placed in the current column
or should span all columns of a multi-column region.

It seems explained what happened in my PDF reports.

Can you tell me what is wrong with my codes, or do you have an example that
works?


Hong Jiang
Received on Tuesday, 17 September 2002 11:04:23 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 3 October 2007 16:06:09 GMT