W3C home > Mailing lists > Public > www-xpath-comments@w3.org > January to March 2002

leading : on qnames

From: David Carlisle <davidc@nag.co.uk>
Date: Thu, 3 Jan 2002 12:10:41 -0500 (EST)
Message-Id: <200201031709.RAA20085@penguin.nag.co.uk>
To: xsl-list@lists.mulberrytech.com
CC: www-xpath-comments@w3.org

Mike Kay said (on xsl-list)

> The option of a leading colon on element names is there only for
> compatibility with XQuery, which does have reserved words. 

I think that the use of reserved words in a language designed to query
arbitrary XML documents is a rather strange design decision.

If Xquery decides that it wants to do that then the quoting mechanism
should be specified as part of Xquery not as part of Xpath so that it
does not affect other uses of Xpath.

The use of a : as the quote character seems particularly unfortunate
since it is already somewhat overloaded in its use in namespace prefixes
and axis specifiers, but whatever the character is, it ought to be in
the xquery specific part of the syntax.

David

_____________________________________________________________________
This message has been checked for all known viruses by Star Internet
delivered through the MessageLabs Virus Scanning Service. For further
information visit http://www.star.net.uk/stats.asp or alternatively call
Star Internet for details on the Virus Scanning Service.
Received on Thursday, 3 January 2002 13:12:42 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 3 October 2007 16:05:54 GMT