W3C home > Mailing lists > Public > www-xml-schema-comments@w3.org > July to September 2005

[Bug 1930] New: R-183: Question about default values

From: <bugzilla@wiggum.w3.org>
Date: Thu, 01 Sep 2005 16:10:44 +0000
To: www-xml-schema-comments@w3.org
Cc:
Message-Id: <E1EAreG-0008SW-Lj@wiggum.w3.org>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=1930

           Summary: R-183: Question about default values
           Product: XML Schema
           Version: 1.0
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: XSD Part 1: Structures
        AssignedTo: ht@w3.org
        ReportedBy: sandygao@ca.ibm.com
         QAContact: www-xml-schema-comments@w3.org


It's not clear from the spec what to do in this case. Bullet 5.2.2.2 of 
constraint [1] deals with default element values. 5.2.2.2.1 talks about complex 
types with mixed content, and 5.2.2.2.2 talks about complex types with simple 
type content. So there is no rule for elements with simple types.

Maybe 5.2.2.2.2 should be changed to say if the actual type is a simple type or 
if it's a complex type with simple type content?

[1] http://www.w3.org/TR/xmlschema-1/#cvc-elt

See the first issue raised in :
http://lists.w3.org/Archives/Member/w3c-xml-schema-ig/2002Nov/0234.html 

Also see a response:
http://lists.w3.org/Archives/Public/www-xml-schema-
comments/2002OctDec/0056.html
Received on Thursday, 1 September 2005 16:10:51 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Sunday, 6 December 2009 18:13:09 GMT