W3C home > Mailing lists > Public > www-xml-schema-comments@w3.org > July to September 2005

[Bug 1891] New: R-128: Question re: leading zeros for gYearMonth and gMonth

From: <bugzilla@wiggum.w3.org>
Date: Fri, 26 Aug 2005 13:43:59 +0000
To: www-xml-schema-comments@w3.org
Cc:
Message-Id: <E1E8eUx-0006iu-Bg@wiggum.w3.org>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=1891

           Summary: R-128: Question re: leading zeros for gYearMonth and
                    gMonth
           Product: XML Schema
           Version: 1.0
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: XSD Part 2: Datatypes
        AssignedTo: cmsmcq@w3.org
        ReportedBy: sandygao@ca.ibm.com
         QAContact: www-xml-schema-comments@w3.org


It is not precisely clear from the XML Schema Datatypes specification whether 
leading zeros are permitted in instances of gYearMonth and gYear when (the 
absolute value of) the year in question is outside the range of 0001 to 9999. 
However, in the otherwise analogous passage of the specification of dateTime, 
such ambiguity is not present (such leading zeros are prohibited), and a 
reasonable interpretation in these other two cases is to straightforwardly 
follow that precedent. 

See bullet (vii) from :
http://lists.w3.org/Archives/Public/www-xml-schema-
comments/2002JanMar/0873.html
Received on Friday, 26 August 2005 13:44:03 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Sunday, 6 December 2009 18:13:09 GMT