W3C home > Mailing lists > Public > www-xml-schema-comments@w3.org > July to September 2004

Re: error in http://www.w3.org/TR/xmlschema-0/#ref36

From: David Fallside <fallside@us.ibm.com>
Date: Wed, 8 Sep 2004 08:22:36 -0700
To: "Waddell, Richard L. (DJ)" <Richard.Waddell@jhuapl.edu>
Cc: www-xml-schema-comments@w3.org
Message-ID: <OFD2AD5A25.E5C6E67D-ON88256F09.005463D6-88256F09.005477B9@us.ibm.com>





DJ, thanks for the comment. I am forwarding to the schema comment list.

======================
David Fallside
Data Management Stds & OS
Tel 530.477.7169
(TL 544.9665)




                                                                           
             "Waddell, Richard                                             
             L. (DJ)"                                                      
             <Richard.Waddell@                                          To 
             jhuapl.edu>               David Fallside/Santa                
                                       Teresa/IBM@IBMUS                    
             09/08/2004 08:06                                           cc 
             AM                                                            
                                                                   Subject 
                                       error in                            
                                       http://www.w3.org/TR/xmlschema-0/#r 
                                       ef36                                
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           




Hi David-


I noticed an inconsistency in the discussion of default values on this web
page: http://www.w3.org/TR/xmlschema-0/#ref36 and you were listed as
editor, so I thought I'd drop you a note.


In Table 1 it says this: "element/attribute may appear once; if it does not
appear its value is 37, otherwise its value is that given."


But in a preceding paragraph it says this: "Default attribute values apply
when attributes are missing, and default element values apply when elements
are empty."


So I think the table is correct only for attributes.  A correction would be
this: "element/attribute may appear once.  If an attribute does not appear
its value is 37, otherwise its value is that given.  If an element does not
appear, it is not assigned any value.  If an element appears with no value
provided for it, its value is 37."


-DJ
Richard (DJ) L. Waddell Jr.
Johns Hopkins University
Applied Physics Laboratory
11100 Johns Hopkins Road
Laurel MD 20723-6099
240-228-5878 (DC area)
443-778-5878 (Balto. Area)
richard.waddell@jhuapl.edu






graycol.gif
(image/gif attachment: graycol.gif)

pic20441.gif
(image/gif attachment: pic20441.gif)

ecblank.gif
(image/gif attachment: ecblank.gif)

Received on Wednesday, 8 September 2004 15:29:17 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 5 February 2014 23:39:42 UTC