W3C home > Mailing lists > Public > www-ws-desc@w3.org > December 2006

Downloading and Installing Eclipse WTP M-1.5.3: Be sure to download emf-sdo-xsd-SDK-...zip

From: Arthur Ryman <ryman@ca.ibm.com>
Date: Thu, 21 Dec 2006 11:00:00 -0500
To: www-ws-desc@w3.org, woden-dev@ws.apache.org
Message-ID: <OF7ADF2BB1.26D63340-ON8525724B.005614E5-8525724B.0057E39F@ca.ibm.com>
FYI,

There is a fix to the WS-I logger in the WTP 1.5.3 maintenance stream. It 
now logs GET requests. 

You need to download various prereqs to install this. Note that the final 
WTP 1.5.3 release will have an easy-to-install "All in One" zip.

One of the prereqs, EMF is tricky since you need the right one. The 
following thread shows an easy error to make [1]

You need to download emf-sdo-xsd-SDK-....zip 

[1] http://dev.eclipse.org/mhonarc/lists/wtp-dev/msg04904.html


Arthur Ryman,
IBM Software Group, Rational Division

blog: http://ryman.eclipsedevelopersjournal.com/
phone: +1-905-413-3077, TL 969-3077
assistant: +1-905-413-2411, TL 969-2411
fax: +1-905-413-4920, TL 969-4920
mobile: +1-416-939-5063, text: 4169395063@fido.ca
----- Forwarded by Arthur Ryman/Toronto/IBM on 12/21/2006 10:40 AM -----

Arthur Ryman/Toronto/IBM
12/21/2006 10:35 AM

To
keith godwin chapman <keith@wso2.com>
cc
chinthaka@wso2.com, Jonathan Marsh <jonathan@wso2.com>, Lawrence 
Mandel/Toronto/IBM@IBMCA
Subject
Re: Need help on WSDL interop





Keith,

Sounds like maybe a  problem with the way you installed the prereqs. It's 
easy to download the wrong emf code. Have a look at this mail thread [1].

If that is not the problem then please report this. There should be no 
change in function since this is a maintenance release - just bug fixes 
are included.

[1] http://dev.eclipse.org/mhonarc/lists/wtp-dev/msg04904.html

Arthur Ryman,
IBM Software Group, Rational Division

blog: http://ryman.eclipsedevelopersjournal.com/
phone: +1-905-413-3077, TL 969-3077
assistant: +1-905-413-2411, TL 969-2411
fax: +1-905-413-4920, TL 969-4920
mobile: +1-416-939-5063, text: 4169395063@fido.ca



keith godwin chapman <keith@wso2.com> 
12/21/2006 02:49 AM

To
Jonathan Marsh <jonathan@wso2.com>, Lawrence Mandel/Toronto/IBM@IBMCA, 
Arthur Ryman/Toronto/IBM@IBMCA
cc
chinthaka@wso2.com
Subject
Re: Need help on WSDL interop






Hi Lawrence,

I just downloaded the wtp-M-1.5.3-200612140559.zip and installed the new 
plugins. This does not even have the link to save messages as it used to 
have. Has this capability been removed? How can I save the log messages?

Thanks,
Keith


Jonathan Marsh wrote:
> Aren't we already running a 1.5.3 beta?
>
> Jonathan Marsh - http://www.wso2.com - 
http://auburnmarshes.spaces.live.com
> 
>
> 
>> -----Original Message-----
>> From: Eran Chinthaka [mailto:chinthaka@wso2.com]
>> Sent: Wednesday, December 20, 2006 5:53 AM
>> To: Lawrence Mandel
>> Cc: Arthur Ryman; 'keith godwin chapman'; Jonathan Marsh
>> Subject: Re: Need help on WSDL interop
>>
>> Hi Lawrence,
>>
>> Thanks for the prompt reply.
>>
>> Keith was complaining about a SOAP 1.2 error. Is that also fixed?
>>
>> Keith, we need to look in to the logger again with the new fixes.
>>
>> -- Chinthaka
>>
>>
>>
>> Lawrence Mandel wrote:
>> 
>>> Hi Chinthaka,
>>>
>>> WRT the Eclipse WTP logger, David Lauzon put in a fix for the logger
>>> recently that will be in the 1.5.3 builds (not yet released). If
>>> you're using an older version (1.5.2 or before) of WTP I suggest you
>>> try a recent 1.5.3 build, which you can obtain from
>>> http://download.eclipse.org/webtools/downloads/
>>> <http://download.eclipse.org/webtools/downloads/> .
>>>
>>> WRT Woden-110, John Kaputin commented on that Jira today that
>>>
>>> " Support for HTTPLocation added via rev 488539. See comments in
>>> WODEN-86 <http://issues.apache.org/jira/browse/WODEN-86> for
>>> details/discussion. That JIRA is for the templated http location in
>>> MessageTest1G. This JIRA is for the same problem (and solution) in
>>> MessageTest2G. "
>>>
>>> Woden-110 is targeted for the M7 milestone, currently scheduled for
>>> Jan. 15. See http://issues.apache.org/jira/browse/WODEN-110
>>> <http://issues.apache.org/jira/browse/WODEN-110> .
>>>
>>>
>>> Lawrence Mandel
>>>
>>> Software Developer
>>> IBM Rational Software
>>> Phone: 905 - 413 - 3814   Fax: 905 - 413 - 4920
>>> lmandel@ca.ibm.com
>>>
>>>
>>> *"Jonathan Marsh" <jonathan@wso2.com>*
>>>
>>> 12/19/2006 11:30 PM
>>>
>>>
>>> To
>>>              <chinthaka@wso2.com>, Arthur Ryman/Toronto/IBM@IBMCA, 
Lawrence
>>> Mandel/Toronto/IBM@IBMCA
>>> cc
>>>              "'keith godwin chapman'" <keith@wso2.com>
>>> Subject
>>>              RE: Need help on WSDL interop
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> Adding Lawrence in case Arthur is on vacation as I suspect ;-).
>>>
>>> Jonathan Marsh - http://www.wso2.com -
>>> http://auburnmarshes.spaces.live.com
>>>
>>>
>>> 
>>>> -----Original Message-----
>>>> From: Eran Chinthaka [mailto:chinthaka@wso2.com]
>>>> Sent: Tuesday, December 19, 2006 8:33 AM
>>>> To: Arthur Ryman
>>>> Cc: Jonathan Marsh; keith godwin chapman
>>>> Subject: Need help on WSDL interop
>>>>
>>>> Hi Arthur,
>>>>
>>>> We are having some problems with Woden and Eclipse logger and we
>>>> appreciate if you can help by fixing them for us to proceed.
>>>>
>>>> We have a problem with message logging. The problem with logging the
>>>> messages is that the eclipse logger does not support SOAP 1.2. It
>>>> 
>> gives
>> 
>>>> validation errors and does not save the messages correctly. Currently
>>>> 
>> we
>> 
>>>> have completely finished MessageTest-1G and ModuleComposition-1G, but
>>>> unable to generate the logs because of the reason above.
>>>>
>>>> Now we are working on the HTTPBinding stuff, we have done most of the
>>>> work on them. We have a bit of a problem because Woden is not parsing
>>>> 
>> in
>> 
>>>> the HttpLocation stuff correctly (Its because it uses the URI class 
of
>>>> JAVA, and this class does not support having curly braces in the URI
>>>> 
>> and
>> 
>>>> stuff. As you know whttp:location value contains curly braces). Keith
>>>> had filed a JIRA (Woden-110) on this and fixing this is very 
important
>>>> for us to work on HTTP binding and to stick to our promised schedule.
>>>>
>>>> Your help with this is greatly appreciated.
>>>>
>>>> Thanks,
>>>> Chinthaka
>>>> 
>>>
>>> 
>
>
>
> 
Received on Thursday, 21 December 2006 16:00:16 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:58:43 GMT