W3C home > Mailing lists > Public > www-ws-desc@w3.org > December 2006

Fw: Need help on WSDL interop

From: Arthur Ryman <ryman@ca.ibm.com>
Date: Thu, 21 Dec 2006 10:29:53 -0500
To: www-ws-desc@w3.org, woden-dev@ws.apache.org
Message-ID: <OFF543CC36.373F0C72-ON8525724B.0054214E-8525724B.0055217F@ca.ibm.com>
FYI,

The Eclipse logger now has a fix for logging GET in M-1.5.3.

Arthur Ryman,
IBM Software Group, Rational Division

blog: http://ryman.eclipsedevelopersjournal.com/
phone: +1-905-413-3077, TL 969-3077
assistant: +1-905-413-2411, TL 969-2411
fax: +1-905-413-4920, TL 969-4920
mobile: +1-416-939-5063, text: 4169395063@fido.ca
----- Forwarded by Arthur Ryman/Toronto/IBM on 12/21/2006 10:18 AM -----

Arthur Ryman/Toronto/IBM
12/21/2006 08:31 AM

To
chinthaka@wso2.com, David Lauzon/Toronto/IBM
cc
Jonathan Marsh <jonathan@wso2.com>, keith godwin chapman <keith@wso2.com>
Subject
Re: Need help on WSDL interop





Eran,

Sorry for the slow reply - been on "vacation" writing my book on WTP.

David Lauzon fixed the "GET" problem. [1] I tested and verified this fix. 
Try to reproduce your problem on the latest 1.5.3 maintenance build. [2]

If you still have the problem, please open a Bugzilla with the details. I 
am sure David will be responsive.

Have you tried using the command line version too?

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=164941
[2] 
http://download.eclipse.org/webtools/downloads/drops/R1.5/M-1.5.3-200612140559/

Arthur Ryman,
IBM Software Group, Rational Division

blog: http://ryman.eclipsedevelopersjournal.com/
phone: +1-905-413-3077, TL 969-3077
assistant: +1-905-413-2411, TL 969-2411
fax: +1-905-413-4920, TL 969-4920
mobile: +1-416-939-5063, text: 4169395063@fido.ca



Eran Chinthaka <chinthaka@wso2.com> 
12/19/2006 11:33 AM
Please respond to
chinthaka@wso2.com


To
Arthur Ryman/Toronto/IBM@IBMCA
cc
Jonathan Marsh <jonathan@wso2.com>, keith godwin chapman <keith@wso2.com>
Subject
Need help on WSDL interop






Hi Arthur,

We are having some problems with Woden and Eclipse logger and we
appreciate if you can help by fixing them for us to proceed.

We have a problem with message logging. The problem with logging the
messages is that the eclipse logger does not support SOAP 1.2. It gives
validation errors and does not save the messages correctly. Currently we
have completely finished MessageTest-1G and ModuleComposition-1G, but
unable to generate the logs because of the reason above.

Now we are working on the HTTPBinding stuff, we have done most of the
work on them. We have a bit of a problem because Woden is not parsing in
the HttpLocation stuff correctly (Its because it uses the URI class of
JAVA, and this class does not support having curly braces in the URI and
stuff. As you know whttp:location value contains curly braces). Keith
had filed a JIRA (Woden-110) on this and fixing this is very important
for us to work on HTTP binding and to stick to our promised schedule.

Your help with this is greatly appreciated.

Thanks,
Chinthaka




Received on Thursday, 21 December 2006 15:31:25 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:58:43 GMT