W3C home > Mailing lists > Public > www-ws-desc@w3.org > April 2005

RE: Consistency of WSDL Component property names

From: Arthur Ryman <ryman@ca.ibm.com>
Date: Tue, 12 Apr 2005 18:19:03 -0400
To: "Jonathan Marsh" <jmarsh@microsoft.com>
Cc: "John Kaputin" <KAPUTIN@uk.ibm.com>, www-ws-desc@w3.org, www-ws-desc-request@w3.org
Message-ID: <OFFEDF3140.33520CA4-ON85256FE1.007A0C50-85256FE1.007A96EA@ca.ibm.com>
Jonathan,

I've been assigned LC107 and I'll make these changes.

Arthur Ryman,
Rational Desktop Tools Development

phone: +1-905-413-3077, TL 969-3077
assistant: +1-905-413-2411, TL 969-2411
fax: +1-905-413-4920, TL 969-4920
mobile: +1-416-939-5063, text: 4169395063@fido.ca
intranet: http://labweb.torolab.ibm.com/DRY6/



"Jonathan Marsh" <jmarsh@microsoft.com> 
Sent by: www-ws-desc-request@w3.org
04/06/2005 08:46 PM

To
"John Kaputin" <KAPUTIN@uk.ibm.com>, <www-ws-desc@w3.org>
cc

Subject
RE: Consistency of WSDL Component property names







This is issue LC107, which we delegated to the editors to change along
the lines you suggest or come back to the WG with further questions.
We're a little behind on our editorial tasks, but expect to implement
this one in the next few weeks.  Thanks for your patience!

[1] http://www.w3.org/2002/ws/desc/4/lc-issues/issues.html#LC107

> -----Original Message-----
> From: www-ws-desc-request@w3.org [mailto:www-ws-desc-request@w3.org]
> On Behalf Of John Kaputin
> Sent: Thursday, March 31, 2005 5:01 AM
> To: www-ws-desc@w3.org
> Subject: RE: Consistency of WSDL Component property names
> 
> 
> I am trying to implement the WSDL 2.0 spec with an API that matches
> the
> WSDL 2.0 component model, but I see that the property name
> inconsistencies
> reported previously still exist in the spec. I couldn't see any
> entries in
> the Issues Lists about this. Can anyone on the WG indicate if/when
> these
> will be corrected?
> 
> There were two issues:
> 1. the word 'reference' was incorrectly used in some property names to
> refer to components that were not XXXReference components
> 2. whether to use short-hand names like {fault} and {faults} or full
> descriptive names like {interface fault} and {binding faults}
> 
> I am most concerned with issue 1. Three property name changes are
> required:
> 
> FaultReference {fault reference}  becomes  {fault} or {interface
> fault}
> (because the property refers to an InterfaceFault component)
> 
> BindingFault {fault reference}  becomes  {fault} or {interface fault}
> (because the property refers to an InterfaceFault component)
> 
> BindingOperation {operation reference}  becomes  {operation} or
> {interface
> operation}
> (because the property refers to an InterfaceOperation component)
> 
> Note, the following uses of 'reference' are correct:
> 
> InterfaceOperation {fault references}  .... a set of FaultReference
> InterfaceOperation {message references} .... a set of MessageReference
> BindingMessageReference {message reference} .... a MessageReference
> BindingOperation {message references} .... a set of Binding Message
> Reference (1)
> BindingOperation {fault references} .... a set of
> BindingFaultReference (2)
> BindingFaultReference {fault reference} .... a FaultReference
> 
> (1) so maybe {binding message references} could be used?
> (2) so maybe {binding fault references}?
> 
> John Kaputin
> Hursley Laboratory
> IBM UK
> ----- Forwarded by John Kaputin/UK/IBM on 31/03/2005 12:02 -----
> 
>              Asir Vedamuthu
>              <asirv@webmetho
>              ds.com>
> To
>                                      John Kaputin/UK/IBM@IBMGB,
>              11/02/2005              www-ws-desc@w3.org
>              22:22
> cc
> 
> 
> Subject
>                                      RE: Consistency of WSDL Component
>                                      property names
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> +1, continuing along these lines, I request the following changes ...
> 
> Binding Operation.{operation reference} =>
>     Binding Operation.{interface operation}
> 
> Binding Operation.{message references} =>
>     Binding Operation.{binding message references}
> 
> Taking LC55 [1] into account ...
> 
> Binding Fault Reference.{fault reference} =>
>     Binding Fault Reference.{interface fault reference}
> 
> Binding Message Reference.{message reference} =>
>     Binding Message Reference.{interface message reference}
> 
> 
> I request the WG to consider the following ...
> 
> Similar to (Interface Operation, Binding Operation), (Interface Fault,
> Binding Fault), ...
> 
> Fault Reference => Interface Fault Reference
> Message Reference => Interface Message Reference
> 
> That leads to ...
> 
> Interface Operation.{fault references} =>
>     Interface Operation.{interface fault references}
> 
> Interface Operation.{message references} =>
>     Interface Operation.{interface message references}
> 
> [1] http://www.w3.org/2002/ws/desc/4/lc-issues/issues.html#LC55
> 
> Regards,
> Asir S Vedamuthu
> asirv at webmethods dot com
> http://www.webmethods.com/
> 
> -----Original Message-----
> From: www-ws-desc-request@w3.org [mailto:www-ws-desc-request@w3.org]
> On
> Behalf Of John Kaputin
> Sent: Thursday, February 10, 2005 8:04 AM
> To: www-ws-desc@w3.org
> Subject: Consistency of WSDL Component property names
> 
> 
> 
> 
> 
> 
> I'd like to suggest some improvements in the consistency of property
> names
> in the Component Model (WSDL 2.0 Part 1 spec, Section 2 Component
> Model)
> 
> ElementDeclaration is referred to by properties in various components:
> 
> Description has property {element declarations}  - a set of
> ElementDeclaration
> InterfaceFault has property {element}                  - an
> ElementDeclaration
> MessageReference has property {element}         - an
> ElementDeclaration
> 
> For clarity, could same name be used for properties that refer to the
> same
> type of component (with adjustments for plural or singular):
> Description {elements}
> InterfaceFault {element}
> MessageReference {element}
> 
> ==================
> 
> There is a similar inconsistency with the names of fault properties:
> 
> Interface {faults} - a set of InterfaceFault
> InterfaceOperation {fault references} - a set of FaultReference
> FaultReference {fault reference} - an InterfaceFault
> BindingFault {fault reference} - an InterfaceFault
> 
> The use of {fault references} for InterfaceOperation makes sense, but
> its
> use in FaultReference and BindingFault is confusing. For example, a
> FaultReference {fault reference} refers to an InterfaceFault that must
> be a
> member of the parent Interface {faults} so why not use the same
> property
> name for both?
> 
> In this example, the {fault reference} property in FaultReference and
> BindingFault could be simply {fault}, thus:
> FaultReference {fault} - an InterfaceFault
> BindingFault {fault} - an InterfaceFault
> 
> ==========================
> 
> Perhaps property names could be made not only consistent but more
> descriptive by basing them on the name of the Component they refer to.
> This
> would facilitate the creation of APIs based closely on the WSDL
> Component
> Model that are more descriptive (eg: the getter/setter methods for
> properties).
> 
> Thus...
> 
> Description {element declarations} - a set of ElementDeclaration
> InterfaceFault {element declaration} - an ElementDeclaration
> MessageReference {element declaration} - an ElementDeclaration
> 
> and...
> 
> Interface {interface faults} - a set of InterfaceFault
> InterfaceOperation {fault references} - a set of FaultReference
> FaultReference {interface fault} - an InterfaceFault
> BindingFault {interface fault} - an InterfaceFault
> 
> This would also clarify the use of operations and faults across
> Interfaces
> and Bindings:
> 
> Interface {fault} - an InterfaceFault
> Binding {fault} - a BindingFault
> 
> could become...
> 
> Interface {interface fault} - an InterfaceFault
> Binding {binding fault} - a BindingFault
> 
> And....
> 
> Interface {operations} - a set of InterfaceOperation
> Binding {operations} - a set of BindingOperation
> 
> could become...
> 
> Interface {interface operations} - a set of InterfaceOperation
> Binding {binding operations} - a set of BindingOperation
> 
> 
> regards,
> John Kaputin
> Hursley Laboratory
> IBM UK Ltd
> 
> 
Received on Tuesday, 12 April 2005 22:19:09 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:58:35 GMT