W3C home > Mailing lists > Public > www-ws-arch@w3.org > May 2003

Re: Separate concepts for "service" and "targetResource?" (was RE : /service/@targetResource ?)

From: Jon Dart <jdart@tibco.com>
Date: Fri, 23 May 2003 10:22:01 -0700
Message-ID: <3ECE58B9.3070406@tibco.com>
To: Assaf Arkin <arkin@intalio.com>
CC: "Champion Mike" <Mike.Champion@SoftwareAG-USA.com>, www-ws-arch@w3.org

Assaf Arkin wrote:
> In the case would it be fair to say that this is nothing than some common name that correlates multiple service definitions together? Something like a service set. 

This is also my understanding, from the discussion so far. And if so, 
the concept is interesting and, I think, possibly useful, but 
"targetResource" is a bad name for it.

Also if you don't allow >1 target resource/service, I fail to see why 
you just aren't using aggregration rather than a linking concept .. IMO 
the whole reason for needing this comes from not allowing > 1 interface 
per service (which our rep opposed, I believe).

--Jon
Received on Friday, 23 May 2003 13:22:19 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 3 July 2007 12:25:19 GMT