W3C home > Mailing lists > Public > www-webont-wg@w3.org > January 2003

ISSUE: owl:Class name misleading; try owl:Set?

From: Dan Connolly <connolly@w3.org>
Date: 01 Jan 2003 14:25:21 -0600
To: www-webont-wg@w3.org
Message-Id: <1041452721.19697.32.camel@dirk.dm93.org>

Based on some comments about sameClassAs

and chatting with a few people about the relationship
between rdfs:Class and owl:Class, I have come to
the conclusion that owl:Set would be a better name
for what we currently call owl:Class.

In RDFS, one can have two classes whose
members are {a,b,c}, but they can be distinct;
the one class might be rdfs:label'ed "first
three letters" and the other might e rdfs:label'ed
"my three favorite letters". RDFS classes have
properties other than their extension.

In DAML+OIL, if they have the same members, they're
the same class.

Gee, to me, that sounds like a set.

In fact, I asked for terms for sets as soon as
I realized how rdfs:Class works:

vocabulary for traditional sets
From: Dan Connolly (connolly@w3.org)
Date: Tue, Nov 06 2001

We already use set-theoretic terms like
intersectionOf, unionOf...
so I think owl:Set is a better name for what
we call owl:Class. And owl:sameMembersAs
is probably better than owl:sameClassAs.

These should be theorems in full owl:

	?X owl:sameMembersAs ?Y
	?X rdfs:subClassOf ?Y.
	?Y rdfs:subClassOf ?X.


	?X rdf:type owl:Set.
	?Y rdf:type owl:Set.
	?X owl:sameMembersAs ?Y.
	?X owl:sameAs ?Y.

(we did rename equivalentTo to sameAs, didn't we?
I should look that up...)

I suppose this is a new issue; I don't think I could
argue that it's an editorial fix. Sorry I didn't
get it in sooner.

Dan Connolly, W3C http://www.w3.org/People/Connolly/
Received on Wednesday, 1 January 2003 15:25:05 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:56:50 UTC