W3C home > Mailing lists > Public > www-webont-wg@w3.org > September 2002

minor naming quibble

From: pat hayes <phayes@ai.uwf.edu>
Date: Mon, 23 Sep 2002 21:02:14 -0500
Message-Id: <p05111b4ab9b5733de4df@[65.217.30.172]>
To: www-webont-wg@w3.org

After burrowing through OWL so intently, I am left with some 
befuddlement about the terminology, so a few suggestions for the 
group to consider.

1. We seem to use 'thing', 'object' and 'individual' at various 
places to mean the same, er,  thing, ie the entities that are not 
classes or properties or datatype values, the things in the classes. 
Wouldnt it be better to harmonize this by sticking to one term? For 
example, lets stick to Object (owl:ThingProperty sounds kind of 
weird.). Then owl:Thing should be owl:Object, and 
owl:sameIndividualAs and owl:differentIndividualFrom (surely the 
worst reserved word invented so far in this century) would be 
owl:sameObjectAs and owl:differentObjectFrom respectively. But read 
on.

2. There is a widespread need for a simple notion of basic identity. 
Both Peter's MT and the OWL/RDF MT provide for such a widespread 
usage. So why not just call them
owl:sameAs and owl:differentFrom, without the qualification? (Or even 
owl:same and owl:different ??) Then the strict version of OWL can 
still easily distinguish sameAs/sameClassAs/samePropertyAs, but those 
who wish to can use the same/different vocabulary more widely, 
without having to type the extra eleven keys every time. Moreover, in 
the looser framework there is still a significant use for sameAs 
applied to classes, for example, since this provides us with an 
elegant way to talk about extensionality: extensional classes are 
those for which owl:sameClassAs entails owl:sameAs; and similarly for 
properties. This is of course illegal in strict OWL, but its still 
going to be used by those in the wild RDF woods, I bet.

In sum, I suggest the following changes:

owl:Thing  -->   owl:Object
owl:sameIndividualAs   -->  owl:same (or owl:sameAs)
owl:differentIndividualFrom   -->  owl:different (or owl:differentFrom)

Pat

PS. I hesitate to even suggest this, but would owl:= and owl:not= be 
legal qnames?

-- 
---------------------------------------------------------------------
IHMC					(850)434 8903   home
40 South Alcaniz St.			(850)202 4416   office
Pensacola,  FL 32501			(850)202 4440   fax
phayes@ai.uwf.edu 
http://www.coginst.uwf.edu/~phayes
Received on Monday, 23 September 2002 22:02:06 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:57:52 GMT