W3C home > Mailing lists > Public > www-webont-wg@w3.org > September 2002

Re: oneOf (2.4)

From: Deborah McGuinness <dlm@KSL.Stanford.EDU>
Date: Wed, 11 Sep 2002 17:08:20 -0700
Message-ID: <3D7FDAF4.246BAE22@ksl.stanford.edu>
To: Ian Horrocks <horrocks@cs.man.ac.uk>
CC: "Peter F. Patel-Schneider" <pfps@research.bell-labs.com>, ewallace@cme.nist.gov, www-webont-wg@w3.org

enumerationOf works for me.
I have worked with a number of users with classic that had a oneOf construct and
did not have complaints about it  but i have no strong attachment to that name
and agree that enumerationOf captures the notion of the class.
oneOf  came mostly from how someone reads the construct in use in a description.
my saab 900 value restriction on its hasColor property is  oneOf (white, blue,
green)...
it of course is only natural when the property has one value.

another alternative could be
someOf thus having the connotation of potentially choosing more than one value in
the enumerated class.

deborah

Ian Horrocks wrote:

> On September 11, Peter F. Patel-Schneider writes:
> >
> > From: Evan Wallace <ewallace@cme.nist.gov>
> > Subject: Re: oneOf (2.4)
> > Date: Wed, 11 Sep 2002 14:37:02 -0400 (EDT)
> >
> > >
> > >
> > > Dan Connolly responded to Ian's comments on oneOf with:
> > > >>Yes, it's not clear that the improvement justifies the cost
> > > >>of the change... raising an issue and all that...
> > > >
> > >
> > > It doesn't seem a very high cost to me.  Anything that makes the
> > > language more accessible to users is well worth the effort.  Should
> > > I propose a new issue on this or can we cover it with an old one?
> > >
> > > BTW - I have always found oneOf to be a misleading name for this
> > > construct, whereas enumeratedClass identifies its purpose nicely for me.
> > >
> > > -Evan
> > >
> >
> > There are two problems with using enumeratedClass:
> > 1/ EnumeratedClass is the token used to define top-level enumerated classes
> >    in the abstract syntax.
> > 2/ ...Class is better reserved for tokens that define top-level classes,
> >    not descriptions.
> >
> > If a name change is needed, I would prefer owl:enumeration.
>
> I suggested enumerationOf because other properties of this kind end in
> "Of", e.g., intersectionOf, unionOf etc.
>
> Ian
>
> >
> > peter
> >

--
 Deborah L. McGuinness
 Knowledge Systems Laboratory
 Gates Computer Science Building, 2A Room 241
 Stanford University, Stanford, CA 94305-9020
 email: dlm@ksl.stanford.edu
 URL: http://ksl.stanford.edu/people/dlm/index.html
 (voice) 650 723 9770    (stanford fax) 650 725 5850   (computer fax)  801 705
0941
Received on Wednesday, 11 September 2002 20:07:01 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:57:52 GMT