W3C home > Mailing lists > Public > www-webont-wg@w3.org > June 2002

Re: 5.11 hasClass/toClass names

From: <herman.ter.horst@philips.com>
Date: Fri, 7 Jun 2002 14:04:40 +0200
To: webont <www-webont-wg@w3.org>
Message-ID: <OF613A00C5.CA70D11D-ONC1256BD1.004258AD@diamond.philips.com>
I like the suggestions someValuesFrom for hasClass (or required)
and allValuesFrom for toClass (or range).

However, in someValuesFrom the plural is not what is really meant.
This is only a small bug, but we could make it vanish:

I prefer the use of someValueFrom, as one value is enough.
It would then be more symmetric to say eachValueFrom instead of 

Therefore, I prefer the replacement of toClass by eachValueFrom
and the replacement of hasClass by someValueFrom.

(I also made this remark in my comments about the full OWL synopsis, at

Herman ter Horst
Received on Friday, 7 June 2002 08:07:33 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:56:44 UTC