W3C home > Mailing lists > Public > www-webont-wg@w3.org > June 2002

Re: Issue 4.1 UniqueProperty is a bad name

From: Jos De_Roo <jos.deroo.jd@belgium.agfa.com>
Date: Thu, 6 Jun 2002 22:49:23 +0200
To: "Dan Connolly <connolly" <connolly@w3.org>
Cc: "Frank van Harmelen <Frank.van.Harmelen" <Frank.van.Harmelen@cs.vu.nl>, "www-webont-wg" <www-webont-wg@w3.org>
Message-ID: <OF943052BA.CE8D99D4-ONC1256BD0.00722870@agfa.be>


[...]

> Other candidates I've heard of, in case anybody finds them
> preferable...
>
>    <ont:FunctionalProperty rdf:about="#father"/>
>    <ont:ManyToOne rdf:about="#father"/>
>
> By the way... is there a separate issue for UnambiguousProperty
> being a bad name? What would be the analog of HasOnlyOne?
>
> Analogs of the above two:
>
>    <ont:FunctionalProperty rdf:about="#father"/>
>    <ont:Injective rdf:about="#personalMailbox"/>
>
>    (i.e. if ?x personalMailbox ?z
>    and ?y personalMailbox ?z then ?x=?y)
>
>
>    <ont:ManyToOne rdf:about="#father"/>
>    <ont:OneToMany rdf:about="#personalMailbox"/>
>
> I think I prefer ManyToOne and OneToMany.

I prefer those as well

--
Jos
Received on Thursday, 6 June 2002 16:50:01 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:57:50 GMT