W3C home > Mailing lists > Public > www-webont-wg@w3.org > June 2002

Re: Issue 4.1 UniqueProperty is a bad name

From: Dan Connolly <connolly@w3.org>
Date: 06 Jun 2002 12:51:34 -0500
To: Frank van Harmelen <Frank.van.Harmelen@cs.vu.nl>
Cc: www-webont-wg@w3.org
Message-Id: <1023385894.25652.931.camel@dirk>

On Thu, 2002-06-06 at 12:31, Frank van Harmelen wrote:
> 
> 
> I propose to close this issue by renaming this language element
> as HasOnlyOne,
> as first proposed by Pat Hayes in http://lists.w3.org/Archives/Public/www-webont-wg/2002Apr/0146.html:
> 
> "This will allow expressions like HasOnlyOne Father"

Hmm... I'm not sure I like it.

In the presentation syntax I use, that would be:

	:father a ont:HasOnlyOne.

Kinda goofy.

In RDF/XML, it would be:

	<ont:HasOnlyOne rdf:about="#father"/>

Hmm... not too bad. I don't suppose I'd object, if it came to that.
i.e. I can live with that.

Other candidates I've heard of, in case anybody finds them
preferable...

	<ont:FunctionalProperty rdf:about="#father"/>
	<ont:ManyToOne rdf:about="#father"/>

By the way... is there a separate issue for UnambiguousProperty
being a bad name? What would be the analog of HasOnlyOne?

Analogs of the above two:

	<ont:FunctionalProperty rdf:about="#father"/>
	<ont:Injective rdf:about="#personalMailbox"/>

	(i.e. if ?x personalMailbox ?z
	and ?y personalMailbox ?z then ?x=?y)


	<ont:ManyToOne rdf:about="#father"/>
	<ont:OneToMany rdf:about="#personalMailbox"/>

I think I prefer ManyToOne and OneToMany.

-- 
Dan Connolly, W3C http://www.w3.org/People/Connolly/
Received on Thursday, 6 June 2002 13:51:06 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:57:50 GMT