W3C home > Mailing lists > Public > www-webont-wg@w3.org > July 2002

Re: ISSUE:4.1 daml:uniqueProperty

From: Peter F. Patel-Schneider <pfps@research.bell-labs.com>
Date: Fri, 12 Jul 2002 09:04:30 -0400
To: las@olin.edu
Cc: welty@us.ibm.com, www-webont-wg@w3.org
Message-Id: <20020712090430T.pfps@research.bell-labs.com>

From: "Lynn Andrea Stein" <lynn.stein@olin.edu>
Subject: Re: ISSUE:4.1 daml:uniqueProperty
Date: Thu, 11 Jul 2002 22:47:21 -0400

> 
> Christopher Welty wrote:
> 
> > ISSUE 3.4: UniqueProp is a bad name
> 
> ...
> 
> >
> >
> > UniqueProp: Functional, UniqueRange
> > UnambiguousProp: InverseFunctional, UniqueDomain
> 
> Rather than UniqueRange and UniqueDomain, I suggest SingletonRange and
> SingletonDomain.  (Although I kind-of like Functional and InverseFunctional,
> too.)


I vote against SingletonRange and SingletonDomain, as they imply a
singleton range and a singleton domain, respectively, a very different
thing.

I vote for Functional and InverseFunctional.  If we want to be very
pedantic, we could inset a Partial into both.

peter
Received on Friday, 12 July 2002 09:04:42 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:57:51 GMT