W3C home > Mailing lists > Public > www-voice@w3.org > July to September 2003

Re: vxml conformance test #608

From: Jeff Kusnitz <jk@us.ibm.com>
Date: Mon, 29 Sep 2003 16:57:55 -0700
To: Chris Kramp <CKramp@sandcherry.com>
Cc: "'www-voice@w3.org'" <www-voice@w3.org>
Message-ID: <OF3AD87131.F3912C2E-ON88256DB0.0082FBF3-88256DB0.0083A2F6@us.ibm.com>

I don't think it's an error.  When 608-next.vxml is loaded, it's via the 
cgi script (cgi-bin/608-sleep8sec.ircgi), so the VoiceXML browser doesn't 
know that the source (608-next.vxml) is coming from the same directory - 
from the browsers perspective, the source is coming from the cgi-bin 
directory, so the root would be ../608-appRoot.vxml.

When I ran this test, I had a problem related to Perl on my machine - the 
open at about line 72 of the cgi script was "sort of" failing - it was 
actually working correctly, but was $! to be "Inappropriate ioctl for 
device", which caused the if test at 73 to fail, which caused the Perl to 
generate a <goto> rather than including the document contents inline, 
which caused the root document reference in 608-next.vxml to be invalid. I 
fixed it by changing the if test in the Perl to ignore the error when $! 
was "Inappropriate ioctl for device"

Jeff

> I'm wondering if there's an error in the script 608-next.txml that's 
part of
> the conformance suite. In that script, the application document is 
written
> as "../608-appRoot.vxml". However, 608-next.txml and 608-appRoot.txml 
are in
> the same directory, so going up a directory creates an URL that points 
to
> the wrong place.
Received on Monday, 29 September 2003 19:57:58 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 30 October 2006 12:48:58 GMT