W3C home > Mailing lists > Public > www-validator@w3.org > October 2016

no support for validating TLSv1.2 websites

From: Maarten Tromp <maarten@geekabit.nl>
Date: Wed, 26 Oct 2016 17:06:19 +0200
To: www-validator@w3.org
Message-ID: <df092d5e-298a-7ee5-abd2-e1be5f6b4e96@geekabit.nl>
Hi guys,

While trying to validate my website I came across the following problem.

I have been fiddling with the TLS settings on a webserver recently and
it only supports TLSv1.2 at the moment. The validator is unable to
validate my website now. When the webserver supported TLSv1, the
validator worked as expected.

You can reproduce this by trying to validate: https://test.geekabit.nl/


The validator website error message:
Sorry! This document cannot be checked.
    I got the following unexpected response when trying to retrieve
<https://test.geekabit.nl/>:
        500 Can't connect to test.geekabit.nl:443
    If you made recent changes to your domain name (DNS) configuration,
you may also want to check that your domain records are correct, or ask
your hosting company to do so.


You can inspect the webserver TLS settings at:
https://observatory.mozilla.org/analyze.html?host=test.geekabit.nl


The jigsaw css validator does work with TLSv1.2, if that is any help for
you guys.
https://jigsaw.w3.org/css-validator/


Regards,
Maarten
-- 
No trees were harmed in posting this message. However, a lot of
electrons were terribly inconvenienced.



Received on Wednesday, 26 October 2016 15:58:08 UTC

This archive was generated by hypermail 2.3.1 : Friday, 4 November 2016 11:03:20 UTC