W3C home > Mailing lists > Public > www-validator@w3.org > March 2013

Re: Validation failing incorrectly on bad value for encoding name

From: Jaime Iniesta <jaimeiniesta@gmail.com>
Date: Mon, 11 Mar 2013 11:24:50 +0100
Message-ID: <CAKFFWV-OXeYPF7Spd825vSBWM2yaC44HT-ZgV3Qrc6eCyYZ2aQ@mail.gmail.com>
To: "Michael[tm] Smith" <mike@w3.org>
Cc: "www-validator@w3.org" <www-validator@w3.org>
2013/3/11 Michael[tm] Smith <mike@w3.org>
>
> > On a related note, validating "http://twitter.com" makes the validator
> > crash (Java exception) and show a message "Oops. That was not supposed to
> > happen. A bug manifested itself in the application internals. Unable to
> > continue. Sorry. The admin was notified.".
>
> I can't reproduce that. But if you send me the stack trace it outputs to
> the console when that happens, I'll take a look.
>
> By the way, are you running under Java 7? Because there's a known issue
> with Java 7 and the validator:
>
>   http://bugzilla.validator.nu/show_bug.cgi?id=949
>
>
Thanks Michael, that seems to be my issue, here's the stack trace when I
validate "http://twitter.com"

https://gist.github.com/jaimeiniesta/5133273

Here's the guide that I followed to install validator-nu

https://github.com/tlvince/w3c-validator-guide#validatornu-html5-validation

And I have also installed on the same server the CSS validator, which,
following this guide, uses Tomcat 7. Maybe it's because of that that I'm
using Java 7, and I should use Tomcat 6 instead:

https://github.com/tlvince/w3c-css-validator-guide
Received on Monday, 11 March 2013 10:25:20 GMT

This archive was generated by hypermail 2.3.1 : Monday, 11 March 2013 10:25:26 GMT