W3C home > Mailing lists > Public > www-validator@w3.org > September 2007

RE: markup validator windows install problems

From: Allan Smith <webmanager@telfordsteamrailway.co.uk>
Date: Tue, 25 Sep 2007 09:22:37 +0100
To: "'www-validator Community'" <www-validator@w3.org>
Message-ID: <000601c7ff4d$3b3237e0$0600000a@Atlantis>


Thanks for that Oliver
Yes I did install the OpenSP parser.

I have emailed Ville directly - it was indeed my misunderstanding
Or perhaps an unclear question in the first place.

I am still concerned that it might be a folder that does not have
appropriate permissions - but cannot clarify which. 

Yesterday I tried as follows.
Go to DOS Prompt, in Perl/bin folder (it is in the path I checked)
And run 'check.dl' from the command line
D:\perl\bin >perl d:\wwwroot\validator\httpd\cgi-bin\check.pl

This streamed html code to the CMD window- the error did not occur.
Hmm!!!

I also tried modifying OpenSP. As follows
print "Loading XSLoader::load for $module ($file)<br>\n";

    my $libref = dl_load_file($file, 0) or do { 
        require Carp;
        Carp::croak("Can't load '$file' for module $module: " . dl_err
+or());
    };
   print "Loaded XSLoader::load for $module ($file)<br>\n";

All the 'use' commands in 'ceheck.pl' prior to use SGML::Parser::OpenSP show
both the 'Loading' and 'Loaded' messages from the print statements. However
when this 'use' statement is processed the 'Loading' message is displayed
but not the 'Loaded' message - instead the error is generated
Allan Smith
Webmanager
 
Support Telford Steam Railway for free when shopping online with over 400
brand-name retailers including:-
 Amazon, NEXT, M&S, John Lewis, Debenhams, HMV, The Body Shop, Vodafone,
DELL, Woolworths, PLAY.com, Interflora and Comet amongst many others...
TSR Easyfundraisning


-----Original Message-----
From: www-validator-request@w3.org [mailto:www-validator-request@w3.org] On
Behalf Of Olivier Thereaux
Sent: 25 September 2007 03:51
To: Allan Smith
Cc: 'www-validator Community'
Subject: markup validator windows install problems


On Mon, Sep 24, 2007, Allan Smith wrote:
> 
> A summary of my experiences installing a local copy of Validator on XP Pro
> with IIS

Thanks a lot for sharing and documenting your experience.
I hope we can help you through the last hoops, though...
 
> 2.	I followed instruction on
> http://validator.w3.org/docs/install_win.html and downloaded
> http://validator.w3.org/validator.tar.gz (the validator itself) and
> http://validator.w3.org/sgml-lib.tar.gz (the DTDs). I also downloaded
> ActivePerl (version 5.8) and the Perl modules ready-to-install in a single
> zip-file.

Did you also install the opensp parser? 
http://sourceforge.net/project/showfiles.php?group_id=2115&package_id=2869&r
elease_id=380406

> 14.	I have been unable to track down the source of this error as all
> referenced files in the error exist in the paths as given and no-one on
the
> validator email group has offered any suggestions that help to diagnose
the
> problem. I do not have sufficient experience with Perl to investigate
> further. This error is NOT related to the way IIS serves the files and
thus
> I can only conclude that the same problem would exist if Apache was used
> instead. 

Quite likely. I think the problem is with your perl install, but whether
it is just your installation or an incompatibility for all windows
machines is not clear yet.
 
> It is also interesting that advice was given that TEMP files are not used,
> yet are referred to in the OpenSP.pm has, at line 63. This could be a
folder
> that does not exist, does not have a ‘valid’ Windows format patrh or has
> incorrect priviledges.

Ville clarified this. No need to blame misunderstandings on bad
advice... 

I'm still hoping that the few people with a bit more experience with
perl on windows that the average person on this list will speak up -
possibly, so far, they have not looked at the (numerous and thus
offputting) IIS-themed threads. I'm changing the subject of this thread
accordingly.
 
-- 
olivier
Received on Tuesday, 25 September 2007 08:22:21 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:25 GMT