W3C home > Mailing lists > Public > www-validator@w3.org > June 2006

Re: Bundle::W3C::Validator - Bundle of modules required by the W3C Markup Validator

From: Michael Adams <linux_mike@paradise.net.nz>
Date: Mon, 05 Jun 2006 13:53:36 +1200
To: www-validator@w3.org
Message-id: <20060605135336.5318818c.linux_mike@paradise.net.nz>

My reply inline.

On Sun, 04 Jun 2006 19:40:11 +0300
OOzy Pal wrote:

> 
> I am trying to install the Bundle::W3C::Validator perl modules for the
> w3c validator; everything went ok except the HTML::Praser.  Below is
> the msgs I get. Can anyone help me on how to fix this problem.
> 
> Note: I am running Kubuntu Linux-Dapper 6.06
> 
> $perl -MCPAN -e "install Bundle::W3C::Validator"
> 
> CPAN: Storable loaded ok
> Going to read /home/oozy/.cpan/Metadata
>   Database was generated on Sun, 04 Jun 2006 05:28:08 GMT
> CGI is up to date.
> Config::General is up to date.
> Running install for module HTML::Parser
> Running make for G/GA/GAAS/HTML-Parser-3.54.tar.gz
> CPAN: Digest::MD5 loaded ok
> Checksum for
> /home/oozy/.cpan/sources/authors/id/G/GA/GAAS/HTML-Parser-3.54.tar.gz
> ok Scanning cache /home/oozy/.cpan/build for sizes
> HTML-Parser-3.54/
> HTML-Parser-3.54/t/
> HTML-Parser-3.54/t/xml-mode.t
> HTML-Parser-3.54/t/textarea.t
> HTML-Parser-3.54/t/filter-methods.t
> HTML-Parser-3.54/t/crashme.t
> HTML-Parser-3.54/t/handler-eof.t
> HTML-Parser-3.54/t/unicode-bom.t
> HTML-Parser-3.54/t/argspec-bad.t
> HTML-Parser-3.54/t/dtext.t
> HTML-Parser-3.54/t/callback.t
> HTML-Parser-3.54/t/entities.t
> HTML-Parser-3.54/t/argspec.t
> HTML-Parser-3.54/t/comment.t
> HTML-Parser-3.54/t/declaration.t
> HTML-Parser-3.54/t/offset.t
> HTML-Parser-3.54/t/handler.t
> HTML-Parser-3.54/t/plaintext.t
> HTML-Parser-3.54/t/case-sensitive.t
> HTML-Parser-3.54/t/cases.t
> HTML-Parser-3.54/t/marked-sect.t
> HTML-Parser-3.54/t/document.t
> HTML-Parser-3.54/t/filter.t
> HTML-Parser-3.54/t/tokeparser.t
> HTML-Parser-3.54/t/linkextor-rel.t
> HTML-Parser-3.54/t/entities2.t
> HTML-Parser-3.54/t/skipped-text.t
> HTML-Parser-3.54/t/linkextor-base.t
> HTML-Parser-3.54/t/default.t
> HTML-Parser-3.54/t/headparser.t
> HTML-Parser-3.54/t/uentities.t
> HTML-Parser-3.54/t/headparser-http.t
> HTML-Parser-3.54/t/script.t
> HTML-Parser-3.54/t/stack-realloc.t
> HTML-Parser-3.54/t/pod.t
> HTML-Parser-3.54/t/magic.t
> HTML-Parser-3.54/t/options.t
> HTML-Parser-3.54/t/attr-encoded.t
> HTML-Parser-3.54/t/unicode.t
> HTML-Parser-3.54/t/argspec2.t
> HTML-Parser-3.54/t/ignore.t
> HTML-Parser-3.54/t/largetags.t
> HTML-Parser-3.54/t/unbroken-text.t
> HTML-Parser-3.54/t/msie-compat.t
> HTML-Parser-3.54/t/api_version.t
> HTML-Parser-3.54/t/parsefile.t
> HTML-Parser-3.54/t/parser.t
> HTML-Parser-3.54/t/process.t
> HTML-Parser-3.54/t/pullparser.t
> HTML-Parser-3.54/eg/
> HTML-Parser-3.54/eg/hlc
> HTML-Parser-3.54/eg/hanchors
> HTML-Parser-3.54/eg/htextsub
> HTML-Parser-3.54/eg/htitle
> HTML-Parser-3.54/eg/hstrip
> HTML-Parser-3.54/eg/hrefsub
> HTML-Parser-3.54/eg/hform
> HTML-Parser-3.54/eg/hdump
> HTML-Parser-3.54/eg/htext
> HTML-Parser-3.54/lib/
> HTML-Parser-3.54/lib/HTML/
> HTML-Parser-3.54/lib/HTML/Entities.pm
> HTML-Parser-3.54/lib/HTML/PullParser.pm
> HTML-Parser-3.54/lib/HTML/Filter.pm
> HTML-Parser-3.54/lib/HTML/TokeParser.pm
> HTML-Parser-3.54/lib/HTML/LinkExtor.pm
> HTML-Parser-3.54/lib/HTML/HeadParser.pm
> HTML-Parser-3.54/util.c
> HTML-Parser-3.54/Makefile.PL
> HTML-Parser-3.54/hints/
> HTML-Parser-3.54/hints/solaris.pl
> HTML-Parser-3.54/Parser.pm
> HTML-Parser-3.54/TODO
> HTML-Parser-3.54/MANIFEST
> HTML-Parser-3.54/tokenpos.h
> HTML-Parser-3.54/Changes
> HTML-Parser-3.54/mkhctype
> HTML-Parser-3.54/Parser.xs
> HTML-Parser-3.54/mkpfunc
> HTML-Parser-3.54/hparser.c
> HTML-Parser-3.54/README
> HTML-Parser-3.54/hparser.h
> HTML-Parser-3.54/typemap
> Removing previously used /home/oozy/.cpan/build/HTML-Parser-3.54
> 
>   CPAN.pm: Going to build G/GA/GAAS/HTML-Parser-3.54.tar.gz
> 
> Checking if your kit is complete...
> Looks good
> Writing Makefile for HTML::Parser
> cp lib/HTML/PullParser.pm blib/lib/HTML/PullParser.pm
> cp Parser.pm blib/lib/HTML/Parser.pm
> cp lib/HTML/Entities.pm blib/lib/HTML/Entities.pm
> cp lib/HTML/TokeParser.pm blib/lib/HTML/TokeParser.pm
> cp lib/HTML/LinkExtor.pm blib/lib/HTML/LinkExtor.pm
> cp lib/HTML/Filter.pm blib/lib/HTML/Filter.pm
> cp lib/HTML/HeadParser.pm blib/lib/HTML/HeadParser.pm
> /usr/bin/perl /usr/share/perl/5.8/ExtUtils/xsubpp  -typemap
> /usr/share/perl/5.8/ExtUtils/typemap -typemap typemap  Parser.xs >
> Parser.xsc && mv Parser.xsc Parser.c
> /usr/bin/perl mkhctype >hctype.h
> /usr/bin/perl mkpfunc >pfunc.h
> cc -c   -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBIAN
> -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE
> -D_FILE_OFFSET_BITS=64 -O2   -DVERSION=\"3.54\" -DXS_VERSION=\"3.54\"
> -fPIC "-I/usr/lib/perl/5.8/CORE"  -DMARKED_SECTION Parser.c
>   /usr/bin/make  -- NOT OK

/************************
The above line seems to be saying that make doesn't exist where it
expects it. Is it in a sbin/ dir?
************************/


> Running make test
>   Can't test without successful make
> Running make install
>   make had returned bad status, install seems impossible
> HTML::Template is up to date.
> LWP::UserAgent is up to date.
> Net::IP is up to date.
> Set::IntSpan is up to date.
> Text::Iconv is up to date.
> URI is up to date.
> Bundle summary: The following items in bundle Bundle::W3C::Validator
> had installation problems:
>   HTML::Parser

-- 
Michael
 Those that can, do; those that can't, teach.
Received on Monday, 5 June 2006 01:51:39 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:22 GMT