W3C home > Mailing lists > Public > www-validator@w3.org > March 2005

Old Mac OS X

From: Donny Viszneki <smirk@thebuicksix.com>
Date: Thu, 17 Mar 2005 01:40:36 -0500
Message-Id: <69257567746ed75efbc50d2742a3ff77@thebuicksix.com>
To: www-validator@w3.org

Who remembers this one?
http://lists.w3.org/Archives/Public/www-validator/2005Jan/0036.html

Well someone asked me if I ever got it to work, and my answer was no. 
But I looked at it again, and had a hunch, and I have identified the 
problem. My validator now works perfectly with a hack in place, so I 
will reveal the problem to this mailing list so that you can come up 
with a more permanent solution:

    # Temporary filehandles.
    my $spin  = IO::File->new_tmpfile;
    my $spout = IO::File->new_tmpfile;
    my $sperr = IO::File->new_tmpfile;

On Mac OS X, IO::File->new_tmpfile() tries to create a file in /tmp. 
/tmp is owned by the administrator, and grouped under staff. The 
permissions set /tmp only writable to the owner. The www user owns the 
apache httpd threads that the main thread spawns. It didn't seem like a 
good long term solution to change the permissions or the ownership of 
/tmp, but when I temporarily did, the validator worked fine.\

So, if there is a separate function you can use to create these pipes, 
then the problem will be solved. Please let me know what you think.
Received on Thursday, 17 March 2005 06:39:27 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:18 GMT