W3C home > Mailing lists > Public > www-validator@w3.org > September 2004

Re: Problem encountered

From: <Mitchel88@aol.com>
Date: Tue, 28 Sep 2004 15:06:54 EDT
Message-ID: <74.42e8c0bf.2e8b104e@aol.com>
To: lachlan.hunt@lachy.id.au
CC: www-validator@w3.org
 
In a message dated 09/28/2004 12:21:32 AM Eastern Daylight Time,  
lachlan.hunt@iinet.net.au writes:

Mitchel88@aol.com wrote:
> I am running Windows XP Pro...
>  But when I validate the exact same files that are on my hard drive, I  get 
 
> the response:
>  
> "Sorry, I am unable to  validate this document because its content type is  
>  text/plain...

> Are you aware of this problem and, if so, do you  know why it's happening  
and 
> how it can be remedied?  

Yes, it's a bug with service pack 2.  There is a temporary fix  available 
using a registry hack [1], but it causes some other problems on  the 
system, which means it can't be permanently applied.  The best  solution, 
and indeed the recommended solution for anyone developing a  website is 
to use a descent, standards compliant browser that does not  suffer from 
the many bugs and excessive non-standard behaviour that IE  has.  I 
recommend either Firefox [2] or Opera [3].

[1]  http://lists.w3.org/Archives/Public/www-validator/2004Sep/0054.html
[2]  http://getfirefox.com/
[3] http://www.opera.com/

-- 
Lachlan  Hunt
_http://www.lachy.id.au/_ (http://www.lachy.id.au/) 



Thank you for replying (and so quickly).  Yes, I tried it with  Firefox, and 
it worked fine.  But what makes no sense to me is if the  problem, using I.E. 
6.0, has to do with Service Pack 2 (I suspected that it  might), why is it 
that the validator works fine on the Internet files but not  the local files?  
I'm using the same operating system in both instances and  can't understand why 
or how the system allows the validator to work in one  instance, and not the 
other.  Trust me, I don't need a detailed explanation  as to why this is so.  
The important thing to me right now is that W3C is  aware of the problem and 
that it is not the fault of my computer, per se,  or my coding.  Perhaps it 
would be possible to post this "bug" in the  FAQ or Q&A for the benefit of others. 
 Thanks again.
 
Mitch Saed
Received on Tuesday, 28 September 2004 19:07:37 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:15 GMT