W3C home > Mailing lists > Public > www-validator@w3.org > January 2004

Help installing the validator--all pages not valid but no errors

From: Ed Martin <edman007x@mac.com>
Date: Sat, 31 Jan 2004 14:56:15 -0500
To: www-validator@w3.org
Message-Id: <871F9C28-5427-11D8-848B-0003934DD798@mac.com>

i'm trying to get the validator installed and it is saying the the page 
is not valid even though it is (the w3c one says the page is valid 
XHTML 1.0) it is doing this to all pages no matter what, just below 
where it says the page isn't valid it says the results from the sgml 
parser are below, but there is nothing below (no errors, it just goes 
onto show the page source), the outline and parse tree also don't show 
a thing, what is causing this and how can i fix it?

i set debug to 1 in the config file and this is what i get for a command

/usr/local/bin/onsgmls -c /usr/local/validator/htdocs/sgml-lib/sgml.soc 
-E0 -R -wvalid -wnon-sgml-char-ref -wno-duplicate

so i tried running that in the command line and this is what i got

root@mr-slack:/usr/local/apache# /usr/local/bin/onsgmls -c 
/usr/local/validator/htdocs/sgml-lib/sgml.soc -E0 -R -wvalid 
-wnon-sgml-char-ref -wno-duplicate/usr/local/bin/onsgmls:E: cannot find 
"/usr/local/validator/htdocs/sgml-lib/sgml.soc"; tried

but the file it can't find is there

root@mr-slack:/usr/local/apache# ls -lh 
/usr/local/validator/htdocs/sgml-lib/sgml.soc -rwxr-xr-x    1 edman007 
users        7.5K Oct 27  2002 
/usr/local/validator/htdocs/sgml-lib/sgml.soc

and in my apache log this is what i'm getting this

[Sat Jan 31 13:45:45 2004] check: main::iana_charset_blurb() called too 
early to check prototype at /usr/local/apache/htdocs/validator/check 
line 348.
[Sat Jan 31 13:45:45 2004] check: Use of uninitialized value in string 
eq at /usr/local/apache/htdocs/validator/check line 1431, <_GEN_2> line 
1.
[Sat Jan 31 13:45:45 2004] check: Use of uninitialized value in pattern 
match (m//) at /usr/local/apache/htdocs/validator/check line 589.
Received on Saturday, 31 January 2004 14:56:37 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:10 GMT