W3C home > Mailing lists > Public > www-validator@w3.org > January 2004

Re: bug in cvs version since May 2003

From: olivier Thereaux <ot@w3.org>
Date: Wed, 14 Jan 2004 15:01:28 +0900
Message-Id: <182C84F6-4657-11D8-BDC4-000A95E54002@w3.org>
Cc: www-validator@w3.org
To: matt@proweb.co.uk

Hello Matt,

On Jan 14, 2004, at 8:08, matt@proweb.co.uk wrote:
> I've been battling getting the validator to work locally on my 
> FreeBSD4.8 box

We've been working on an install guide:
http://validator.w3.org:8001/docs/install
which could have helped you.

> I made the "mistake" of installing the code into a directory of my 
> choosing instead of /usr/local/validator

That's usually not a problem, see below.

> Mistake because check hard codes the path names
[snip]
> The error was introduced in version 1.324 on 25th May 2003 by link

This version is in the HEAD branch, which is known (although not well 
publicized) to be broken.

It's usually recommended to install either the stable version from 
http://validator.w3.org/source/ but if you want a more recent version 
the one in CVS in the "validator-0_6_0-branch" branch is a relatively 
safe choice, whereas HEAD is "there be dragons".

In any case, thanks and congrats for installing and using the 
validator. Feel free to contact us (either here or on the developers' 
IRC channel) if you have further remarks or questions.
-- 
olivier
Received on Wednesday, 14 January 2004 01:01:31 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:10 GMT