Hello

I've recently downloaded the current CVS build of the HTML validator and installed it on Mandrake Linux 10 using the Apache2 webserver with Perl 5.8.3 and OpenSP 1.5

When I tried it against a new website, I was supplied with the following error:

"
This page is not Valid !

Note:
 The Validator XML support has some limitations.

Below are the results of checking this document for XML well-formedness and validity.

Line 1, column 0: end of document in prolog .
<!DOCTYPE html PUBLIC '-//W3C//DTD XHTML 1.0 Transitional//EN' 'http://www.w3.or
"

The position of the error ( line 1 column 0) made me suspicious so I tested the install against some pages I am confident are well-formed, I was given the same error each time.

I believe this to be a misconfiguration more than anything else but cannot seem to find anything wrong with the install. All Prerequisits are met or exceeded with all perl modules being the latest from CPAN downloaded only yesterday

I would appreciate a little help in overcoming this issue.

validator-httpd.conf  has the following changes from from the default:

In "Directory" I added

  <IfModule mod_access.c>
    Order allow,deny
    Allow from all
  </IfModule>
In    <IfModule mod_perl.c> and <Location "/validator/check">
I uncommented for  Perl 1.99+

The following files went into "/etc/w3c"
charset.cfg
eref.cfg
tips.cfg
type.cfg
types.conf
validator.conf

In validator.conf I enabled private IPs and changed the "Home Page" address. No other changes were made.

All paths have been kept as default ( /usr/local/validator ) and ( /etc/w3c )

Thanktyou in advance
Martin Proffitt


Online Virus Scan: Check your computer online nowScan now!