W3C home > Mailing lists > Public > www-validator@w3.org > October 2003

Re: Quick problem getting the validator working

From: Chris Hyzer <mchyzer@yahoo.com>
Date: Mon, 20 Oct 2003 14:44:21 -0700 (PDT)
Message-ID: <20031020214421.42547.qmail@web10406.mail.yahoo.com>
To: Saqib Ali <saqib@seagate.com>
Cc: www-validator@w3.org


Sorry, I gave a bad example, my linux command was just
supposed to show that no errors were being generated.

When I run lycos through my validator from the web
side, you will see this:


We know this has errors since we see them from the
w3.org validator:


When I run the source code through "onsgmls", I get
the following:

/usr/bin/onsgmls -D
/usr/local/validator/htdocs/sgml-lib -c sgml.soc -E0
-R -wvalid -wnon-sgml-char-ref -wno-duplicate <
lycos.html > lycos.out 2> lycos.err



Any ideas why the validator CGI is not parsing the
output correctly?  I have the right version of
onsgmls, so it should, do working onsgmls commands
produce similar outputs and errors?


--- Saqib Ali <saqib@seagate.com> wrote:
> > [mchyzer@flash bin]$ /usr/bin/onsgmls -D
> > /usr/local/validator/htdocs/sgml-lib -c sgml.soc
> -E0
> > -R -wvalid -wnon-sgml-char-ref -wno-duplicate
> Chris,
> I think you need to specify what html file you want
> to validate to the
> onsgmls.
> here is what I use:
> # onsgmls -E0 -c /path/to/dtd/HTML4.cat -s
> /path/to/dtd/HTML4.decl
> myhtml.html
> If you dont specify any html file, there is will no
> output.
> Saqib Ali
> ---------
> http://validate.sourceforge.net <---
> XHTML/HTML/DocBook Validator
Received on Monday, 20 October 2003 17:44:22 UTC

This archive was generated by hypermail 2.3.1 : Friday, 27 November 2015 11:01:20 UTC