W3C home > Mailing lists > Public > www-validator@w3.org > October 2003

Validator doesn't validate http://vaunt.net, but doesn't show any error

From: Franci Penov <francip@yahoo.com>
Date: Sat, 11 Oct 2003 13:00:43 -0700 (PDT)
Message-ID: <20031011200043.82704.qmail@web13208.mail.yahoo.com>
To: www-validator@w3.org
Cc: francip@yahoo.com

(Please cc me as I am not on the mailing list)

Hi all,

The HTML validator behavior with my page is somewhat strange. I've been trying
to get http://vaunt.net to validate as XHTML 1.1 for the past few months. I've
got it to stage where the validator does not give me any error message, but it
still insist my page is not valid XHTML 1.1.

In addition, what is really confusing me is that the validator insists on the
following form of the <meta> and <link> tags in the <head>:

    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
    <meta http-equiv="P3Pv1" content="http://www.vaunt.net/w3c/p3policy.xml">
    <link rel="stylesheet" type="text/css" href="/Styles/site.css">
    <link rel="stylesheet" type="text/css" href="/Styles/print.css"
media="print">
    <link rel="P3Pv1" href="/w3c/p3p.xml">

Obviously, this is not valid XML, as the tags are not properly closed, and I
thought XHTML is supposed to be valid XML 1.0 document, right? The valid XML
form of <meta> and <link> should be like this:

    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta http-equiv="P3Pv1" content="http://www.vaunt.net/w3c/p3policy.xml" />
    <link rel="stylesheet" type="text/css" href="/Styles/site.css" />
    <link rel="stylesheet" type="text/css" href="/Styles/print.css"
media="print" />
    <link rel="P3Pv1" href="/w3c/p3p.xml" />

However, this causes the validator to sissue an error on the first <meta> tag:

Line 9, column 72: character data is not allowed here 
  ...nt-Type" content="text/html; charset=utf-8" />

I also tried to other XML form for the tags:

    <meta http-equiv="Content-Type" content="text/html; charset=utf-8"></meta>
    <meta http-equiv="P3Pv1"
content="http://www.vaunt.net/w3c/p3policy.xml"></meta>
    <link rel="stylesheet" type="text/css" href="/Styles/site.css"></link>
    <link rel="stylesheet" type="text/css" href="/Styles/print.css"
media="print"></link>
    <link rel="P3Pv1" href="/w3c/p3p.xml"></link>

The error for this is:

Line 9, column 77: end tag for element "META" which is not open (explain...). 
  ...ontent="text/html; charset=utf-8"></meta>
                                             ^
Line 10, column 83: end tag for element "META" which is not open (explain...). 
  ...ww.vaunt.net/w3c/p3policy.xml"></meta>
                                          ^
Line 11, column 73: end tag for element "LINK" which is not open (explain...). 
  ...pe="text/css" href="/Styles/site.css"></link>
                                                 ^
Line 12, column 88: end tag for element "LINK" which is not open (explain...). 
  ...tyles/print.css" media="print"></link>
                                          ^
Line 13, column 48: end tag for element "LINK" which is not open (explain...). 
      <link rel="P3Pv1" href="/w3c/p3p.xml"></link>

If you look at the page source, the only HTML before the first <meta> tag is:

<?xml version="1.0" encoding="utf-8" ?>
<!doctype html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
  <head>
    <title>
      Vaunt.net
    </title>

I tried moving <title> tag after the <meta> and <link> tags with no change in
validator behavior.

Please, help me understand what I am doing wrong here. My page (although it is
generated by code) is very simple and contains no active content (scripts,
java, activex or flash). Hence, I must be doing something really stupid to get
this strange behavios.

Regards,
Franci Penov
Received on Sunday, 12 October 2003 16:12:17 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:10 GMT