W3C home > Mailing lists > Public > www-validator@w3.org > June 2003

Local installation of validator

From: Clemens Weiß <listen@webplain.de>
Date: Fri, 13 Jun 2003 19:30:59 +0200
Message-ID: <00b301c331d1$c05e5780$fe7ba8c0@menslerdesktop>
To: "Liste W3C Validator" <www-validator@w3.org>

Hi,
I've installed the validator (check v. 1.305.2.12) on my SuSE Linux
8.1 with Apache 1.3.26-57
Perl 5.8.0-45
OpenSP 1.5
and the newest versions of CGI.pm, HTML-Parser, libwww-perl,
Set-IntSpan, Text-Iconv and URI (btw. the link to URI on
validator.w3.org/source/ is wrong).

Everytime I validate a page with this local installation, I get the
message "This page is not valid...", but no errors are shown, only the
source is listed (screenshot:
http://www.webplain.de/misc/test/validator.png).
When I use the online W3C-validator with the same page, it's valid.

The command is "/usr/local/bin/onsgmls -c
/usr/local/src/validator/htdocs/sgml-lib/xml.soc -E0 -R -wvalid -wnon-
sgml-char-ref -wno-duplicate -wxml".

After each try I get the following 3 lines in my Apache error log:

[Fri Jun 13 19:17:45 2003] check: main::iana_charset_blurb() called
too early to check prototype at
/usr/local/src/validator/httpd/cgi-bin/check line 348.
[Fri Jun 13 19:17:49 2003] check: Use of uninitialized value in string
eq at /usr/local/src/validator/httpd/cgi-bin/check line 1431, <_GEN_2>
line 1.
[Fri Jun 13 19:17:49 2003] check: Use of uninitialized value in
pattern match (m//) at /usr/local/src/validator/httpd/cgi-bin/check
line 589.

Can anybody help me with this problem?

Thanks.

Have a nice day, greetings from Germany,

Clemens Weiß
--
www.webplain.de
ICQ: 92404126
Received on Friday, 13 June 2003 13:34:44 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:09 GMT