W3C home > Mailing lists > Public > www-validator@w3.org > August 2003

Re: XML doesn't validate but won't say why...

From: Terje Bless <link@pobox.com>
Date: Wed, 27 Aug 2003 15:29:12 +0200
To: "Eric C. Weaver" <weav@sigma.net>
Cc: www-validator@w3.org
Message-ID: <f02000101-1026-729CB612D89211D79CB50030657B83E8@[193.157.66.23]>

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Eric C. Weaver <weav@sigma.net> wrote:

>I tried validating the following document:
>   http://flat5th.homeip.net/weav/dtd/shipconf2.xml
>(it's complete with supplied external references).
>
>The validator says it's not valid XML but gives no specific error messages.
>Is something in my supplied XML or in the external references crashing the
>validator, perhaps?

You have an error in your DTD; the content model is ambiguous. When the
current token is the 1st occurrence of «CandidateListIndicator», both the 1st
and 2nd occurrences of "ArtifactFormatIndicator" are possible.

We have a bug/limitation in the Validator in that it doesn't report errors in
the DTD back to the user. For various (stupid) technical reasons it may be a
while before this issue is addressed.

Thanks for the catch, and the feedback, though. It was very helpfull in
tracking down this issue. I've logged it as Bug #301 —
<http://www.w3.org/Bugs/Public/show_bug.cgi?id=301> — if you want to follow
its progress.

- -- 
"Allright... Calm down! Relax! Start breathin´..."         -- Dr. D.R.E.

-----BEGIN PGP SIGNATURE-----
Version: PGP SDK 3.0.2

iQA/AwUBP0yyJ6PyPrIkdfXsEQLGeQCg5jh7aH6qRScmYplqkbkXsX0BXF8An3HF
oIkHsi72zgP7ZWdXEcT7TiL3
=xVJ4
-----END PGP SIGNATURE-----
Received on Wednesday, 27 August 2003 09:29:25 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:09 GMT