W3C home > Mailing lists > Public > www-validator@w3.org > August 2003

Re: help with validator installation on Solaris 2.8 and apache 2.0.46

From: Ziying Sherwin <sherwin@lhc.nlm.nih.gov>
Date: Fri, 8 Aug 2003 15:41:10 -0400 (EDT)
To: Nick Kew <nick@webthing.com>
Cc: www-validator@w3.org, "R. P. Channing [\"Rick\"] Rodgers" <rodgers@hume.nlm.nih.gov>
Message-ID: <Pine.GSO.4.21.0308081540550.1013-100000@hume.nlm.nih.gov>


Thanks for the advice. It seems that it is related to the Text:Iconv 
installation. When I tried  to test the Text:Iconv by using the following
perl script, I got the same error message complaining about "Unsupported 
conversion: Invalid argument":

use Text::Iconv;

$cd = Text::Iconv->new("roman8", "iso88591");
$a  = "abc";
$b  = $cd->convert($a);
if($a eq $b)
{
    print "ok \n";
}
else
{
    print "not ok \n";
}

We tried to re-build Text:Iconv by adding the "-liconv" to the Makefile:

perl -i.bak -p -e "s/'LIBS'\s*=>\s*\[''\]/'LIBS' => \['-liconv'\]/" Makefile.PL
perl Makefile.PL
make
make test
make install

The "make test" ran without any problem, but we still got the same error message
regarding "Text:Iconv->new()" command.

I know this is not a problem of validator, but does anyone have same experience
about installing Text:Iconv on the Solaris 2.8 platform using gcc? Any help
will be appreciated.

Ziying Sherwin




On Fri, 8 Aug 2003, Nick Kew wrote:

> 
> On Thu, 7 Aug 2003, Ziying Sherwin wrote:
> 
> >     eval {my $c = Text::Iconv->new($result_charset, 'utf-8')};
> 
> > Do you have any ideas what is wrong?
> 
> Doesn't your error log have anything to say?
> 
> Looks to me like a problem with your Perl's iconv installation.  If it
> works from the commandline, then find out what's different in the
> environment Apache feeds it.
> 
> -- 
> Nick Kew
> 
> In urgent need of paying work - see http://www.webthing.com/~nick/cv.html
> 
> 
> 
> 
Received on Friday, 8 August 2003 15:47:06 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:09 GMT