W3C home > Mailing lists > Public > www-validator@w3.org > April 2003

Re: Error messages regressed?

From: Terje Bless <link@pobox.com>
Date: Sat, 19 Apr 2003 06:37:25 +0200
To: W3C Validator <www-validator@w3.org>
cc: Nick Kew <nick@webthing.com>
Message-ID: <a0106000f-1025-9F17611E722011D7B5DF0030657B83E8@[193.157.66.23]>

Nick Kew <nick@webthing.com> wrote:

>I just replied to someone on ciwah, who complained of the message
>
>Line 12, column 3: document type does not allow element "H1" here;
>missing one of "MAP", "IFRAME", "BUTTON" start-tag
><h1>Making Progress</h1>
>
>This is the OpenSP error elementNotAllowed, and it appears to be jjc's
>original error messages.  I would presume this is down to using OpenSP
>out of the box, without Liam's or my customisations of the messages for
>validation.
>
>Can I suggest plugging in either Liam's ParserMessages from lq-nsgmls or
>( IMO  better[1] :-) mine from Valet.
>
>[1] Liam's have too many references to HTML, which are not so good when
>validating non-HTML documents.  Mine are based on Liam's, but reword
>things like that.

I *really* don't want to maintain a patched version of OpenSP for Validator
so for now they'll have to stay. However for the future I'm planning on
completely replacing the messages to be specific to the Validator --
without patching OpenSP -- so this issue will go away.

-- 
Now Playing "I Loves You Porgy" by "Nina Simone"",
 from the album "Feeling Good - The Very Best Of".
Received on Saturday, 19 April 2003 00:37:29 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:08 GMT