W3C home > Mailing lists > Public > www-validator@w3.org > June 2002

Re: FW: Error message: Unknown character set

From: Terje Bless <link@pobox.com>
Date: Fri, 14 Jun 2002 20:11:54 +0200
To: Eric.Lewis@swissinfo.ch
cc: www-validator@w3.org
Message-ID: <r01050300-1015-A9959304801011D6BB0200039300CF5C@[192.168.1.7]>

[ I dropped this on the floor, didn't I? Sorry about that! :-( ]


Eric.Lewis@swissinfo.ch wrote:

>Did anyone install the Validator on a Solaris system?

Nope; and I'll bet this is related. Perhaps your Apache error_log contained
some messages about Text::Iconv or iconv_open? If you don't use a recent
glibc (which Solaris doesn't by default), you need to get libiconv
seperately (or install glibc) for character encoding conversions to work.
It's possible to hack Validator into not doing charset conversions, but I
would strongly reccomend you not attempt this as it's apt to break things
all over the place.


>>Oh, and if you're working from CVS you need to be carefull which branch
>>you check out. The bleeding edge is totally horked ATM and will only
>>run on my specific development box and pretty much nowhere else.
>
>Well, what is the URL of the version you would recommend?

The current CVS HEAD should always be fine. New development is happening on
a branch (validator-0_6_0 ATM).


Apologies again for dropping this issue. Y'all should feel free to ping me
(repeatedly!) if I appear to have forgot about something.

-- 
"I don't want to learn to manage my anger;
 I want to FRANCHISE it!" -- Kevin Martin
Received on Friday, 14 June 2002 23:33:37 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:14:03 GMT