W3C home > Mailing lists > Public > www-validator@w3.org > October 2001

Bug?

From: Petri Rantala <paratronic@kolumbus.fi>
Date: Sun, 7 Oct 2001 14:29:54 -0400 (EDT)
To: <www-validator@w3.org>
Message-ID: <BFELJNAICODCFEMDKFIJGEJHCAAA.paratronic@kolumbus.fi>

Frist thank you for everyone who has been creating this exellent validating
service.


Allthought there is some little confusing issue in it:

When you use the
http://validator.w3.org/
to validate some page, which has no errors, you receive the results
"Concratulations.... ...add this icon to your web page:

  <p>
    <a href="http://validator.w3.org/check/referer"><img border="0"
        src="http://www.w3.org/Icons/valid-html401"
        alt="Valid HTML 4.01!" height="31" width="88"></a>
  </p>
"

Then you add the above HTML to your page, and go to
http://validator.w3.org/checklink
to check the same page, which now has the "valid html"-logo in it, you get
following error message from linkchecker:

--------
List of broken links and redirects
Fragments listed are broken. See the table below to know what action to
take.

Code Occurences What to do
301 1 You should update the link.
http://validator.w3.org/check/referer redirected to
http://validator.w3.org/
What to do: You should update the link.

HTTP Code returned: 301 -> 200
HTTP Message: Moved Permanently -> OK
----------


Regards



Petri Rantala
Puh. 0400-297526
Phone int. +358 400 297526
http://www.paratronic.fi
Received on Monday, 8 October 2001 04:08:43 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:13:59 GMT