W3C home > Mailing lists > Public > www-validator@w3.org > May 2001

Re: Dubious validator error. Validator bug or what ?

From: Christian Smith <csmith@barebones.com>
Date: Wed, 30 May 2001 14:53:24 -0400
To: sysadmin <andreip@rnc.ro>
cc: www-validator@w3.org
Message-ID: <20010530145324-b01010702-ad6a6969-0910-010c@204.107.232.107>
On Wednesday, May 30, 2001 at 5:57 AM, andreip@rnc.ro (sysadmin) wrote:

> Lookig at:
> 
> <li><b><strong><blink>---&gt;</blink><a href="/rh ...
>                         ^
> The validator said:     |
>                         ^
> Error: invalid comment declaration; check your comment syntax
> 
> ???
> What comment ???  That wasn't any comment, it was just an ascii-art
> arrow made out of three dashes and a GT sign (properly encoded 
> as &gt;).
> 
> Care to take a look ?

Post the URL for the page. My bet is that you have a comment earlier in
the page which is not properly formed.

> P.S. Experienced a maybe similar problem with MSIE, in an url like
> http://server.na.me/cgi-bin/cgi-name?x=y&currentdate=today&z=t
> it improperly replaced &curren with asc($)+128. 

This is why you need to entity encode the & in the URL when the URL is
used as the value of an href attribute.

The correct format would be

http://server.na.me/cgi-bin/cgi-name?x=y&amp;currentdate=today&z=t


-- 
Christian Smith  |  csmith@barebones.com  |  http://web.barebones.com

He who dies with the most friends... Is still dead!
Received on Wednesday, 30 May 2001 14:53:28 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:13:58 GMT