W3C home > Mailing lists > Public > www-validator@w3.org > July 2001

Unknown Encoding - Post HTMLTidy wrap

From: Andrew Barker <boab@agn.net.au>
Date: Thu, 19 Jul 2001 21:51:07 +0800
To: www-validator@w3.org
Message-ID: <yam8600.394.5794208@mail.agn.net.au>
Hello, (Thanks for your interesting list discussions since Nov)

Wanted to say thanks for the validator!, that I've been happily using 
for the past couple of years, on an Amiga, with the "IBrowse" user 
agent. All of the recent changes have been appreciated and work well 
on above. 

A recent problem I've now noticed has appeared since I introduced an
Amiga port of D.R.'s HTML Tidy as a plugin to an x+ html4.01 editor, 
I have been creating software for. 

A problem? appears when Tidy wraps a doc. I'd like to know if the way 
this has been wrapped is valid? I do notice that the same document 
validates when attributes within the document wrapped like this after
the "=" (I personally would wrap after an att="value" quote mark).

eg.  
<meta http-equiv="Content-Type" content=
"text/html; charset=ISO-8859-1">

Results in... Unknown!

Document Checked

 Jump to: Outline.

URI: http://www.agn.net.au/~boab/Software/EdHT/about.html
Last modified: Sun Jul 15 04:09:38 2001
Server: Micro$loth (IIS/5.0 ;^)
Content length: 6698
*Character encoding: _unknown_*
Document type: HTML 4.01 Transitional

 Below are the results of attempting to parse this document with an SGML parser.

     No errors found!

Is there any error here? Apologies in advance if this is "old hat"

Regards,
Andrew
-- 
 From Andrew Barker in Kununurra - 40km from the WA/NT border
 in Western AUSTRALIA (3000km from Perth 800km from Darwin :)
 ------------------------------------------------------------
 boAB Software          http://www.agn.net.au/~boab/Software/
   x+html4.0x MenuConfigs for EdHT - HT Editor for Amiga! 
Received on Thursday, 19 July 2001 09:49:36 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:13:59 GMT