W3C home > Mailing lists > Public > www-validator@w3.org > November 2000

Re: Image rollovers by naming image produces error in html validator

From: Andrew Barker <boab@agn.net.au>
Date: Thu, 23 Nov 2000 23:05:50 +0800
To: Steven Rowlandson <steven@creativefactory.com.au>, www-html@w3.org, www-validator@w3c.org
Message-ID: <yam8362.2546.5831480@mail.agn.net.au>
In Reply to steven@creativefactory.com.au 

Hello Steven, on Wednesday 22-Nov-00 you wrote... err typed! 
 Image rollovers by naming image produces error in html validator
> How do make a standard image rollover compliant to w3c 4.01 transitional.

> This is what the validator says..
> <!-- snip
> Line 37, column 200:
>  ... ,'icon01of')"><img src="gui/la_ws_nav01.gif" name="icon01" width="103"
> ...
>                                                        ^
> Error: there is no attribute "NAME"

A week or two ago I was validating some pages to HTML 4.01 and encountered
this error? I checked the DTD and found that I had HTML4.0 DTD, changed 
that to a 4.01 DTD, uploaded and reloaded and it validated. 

As name is a valid attribute for img, is this an error with the validator
against the HTML 4.0 DTD? maybe?

So see if you have a 4.0 DTD?

OK > Steve
Hope this helps?

I have been on www-html for about 12 months, and wish I'd found it earlier,
so thank you all for some enlightening discussions. 

I have been a fan of the validator for last couple of years and just sub'd
to the list there after reading your message.

Regards, 
Andrew :-)
-- 
 From Andrew Barker in Kununurra - 40km from the WA/NT border
 in Western AUSTRALIA (3000km from Perth 800km from Darwin :)
 ------------------------------------------------------------
Received on Thursday, 23 November 2000 10:04:23 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 25 April 2012 12:13:54 GMT