W3C home > Mailing lists > Public > www-validator-cvs@w3.org > June 2012

[Bug 17492] New: html5 input image alt error

From: <bugzilla@jessica.w3.org>
Date: Thu, 14 Jun 2012 23:04:36 +0000
To: www-validator-cvs@w3.org
Message-ID: <bug-17492-169@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=17492

           Summary: html5 input image alt error
           Product: Validator
           Version: HEAD
          Platform: PC
        OS/Version: Windows NT
            Status: NEW
          Severity: normal
          Priority: P2
         Component: HTML5
        AssignedTo: mike+validator@w3.org
        ReportedBy: mike@lunawebs.com
         QAContact: www-validator-cvs@w3.org


tried to validate document and got error message that looks like it's internal
to the validator

"Sorry! This document cannot be checked."
External Checker not available

Checking the Document Type of this document requires the help of an external
tool which was either not enabled in this validator, or is currently
unavailable. Check in the validator's system configuration that HTML5 Validator
is enabled and functional.

The error encountered was: :11: parser error : Premature end of data in tag dl
line 11 to continue. Sorry. The admin was
notified.</message></non-document-error></dd> ^ :11: parser error : Premature
end of data in tag elaboration line 11 to continue. Sorry. The admin was
notified.</message></non-document-error></dd> ^ :11: parser error : Premature
end of data in tag error line 8 to continue. Sorry. The admin was
notified.</message></non-document-error></dd> ^ :11: parser error : Premature
end of data in tag messages line 2 to continue. Sorry. The admin was
notified.</message></non-document-error></dd> ^


To reproduce, simply try validate by direct input:
<!DOCTYPE html>
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>broke</title>
</head>
<body>

<form>
<input type="image" src="http://www.blogger.com/img/add/add2blogger_sm_b.gif"
/>
</form>

</body>
</html>

The missing alt on the input triggers this error, if you put an alt on that it
goes through

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Thursday, 14 June 2012 23:04:39 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 15:17:50 UTC