W3C home > Mailing lists > Public > www-validator-cvs@w3.org > January 2010

[Bug 8653] New: Browser "back" button does not work properly on http://validator.w3.org/

From: <bugzilla@wiggum.w3.org>
Date: Wed, 06 Jan 2010 03:40:27 +0000
To: www-validator-cvs@w3.org
Message-ID: <bug-8653-169@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=8653

           Summary: Browser "back" button does not work properly on
                    http://validator.w3.org/
           Product: Validator
           Version: 0.8.5
          Platform: PC
               URL: http://validator.w3.org/
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Website
        AssignedTo: dave.null@w3.org
        ReportedBy: david@davidhoulder.com
         QAContact: www-validator-cvs@w3.org


To reproduce:

1. Go to http://validator.w3.org/
2. Click the "Validate by File Upload" tab
(URL chnages to http://validator.w3.org/#validate_by_upload and file upload
interface appears)
3. Click the browser "back" button
4. URL changes back to http://validator.w3.org/ but file upload tab remains
selected.

The same behaviour is apparent with all the tabs: clicking on a tab selects it,
but the browser back button won't take you back to previous tabs, despite the
URL changing as you'd expect.

Tested with Firefox 3.0.16

My guess is you need something like this:
http://digitarald.de/project/history-manager/

cheers


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Wednesday, 6 January 2010 03:40:29 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 15:17:41 UTC